Announcement

Collapse
No announcement yet.

Style quickchooser appears in the footer after upgrade to 4.1.11

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Style quickchooser appears in the footer after upgrade to 4.1.11

    After the upgrade to 4.1.11 The style quick chooser appears in the footer.

    In the settings I do not allow the user to change styles.
    The new Mobile style cannot be deleted.

    I removed the chooser by editing the footer template.

    What's the recommended method?

    thanks
    Last edited by Exeter; Wed 29 Feb '12, 10:27pm.

  • #2
    I figured it out;
    The picker disappears when the mobile style is turned off.

    Mobile style->Edit Settings->Allow User Selection->No

    Comment


    • #3
      I don't think this is the issue for me actually. I do notice that in 4.1.11 the mobile styles seem to be grouped separately from the main styles. However, no matter if I set 'allow user selection' to 'yes' or 'no' for the mobile styles no options show up at all in the quick style selector so users are unable to switch from my customized style to the default version and vice versa.

      Comment


      • #4
        Originally posted by espkaruna View Post
        I don't think this is the issue for me actually. I do notice that in 4.1.11 the mobile styles seem to be grouped separately from the main styles. However, no matter if I set 'allow user selection' to 'yes' or 'no' for the mobile styles no options show up at all in the quick style selector so users are unable to switch from my customized style to the default version and vice versa.
        Same. Since the upgrade, there is no option to switch styles. The quickstyle is there but empty, you cannot change it. I also cannot use the mobile theme via my iPhone even though I have gone through and enabled the new version of the mobile theme.

        Help!

        Comment


        • #5
          ^^^Same.

          However, i will say that if i make the vbulletin theme the default, i can select other themes. So my belief is that the custom themes need to be updated and fixed.
          BMW M3 Enthusiast - m3fever.com
          Gamer/Modder - stealthygaming.com

          Comment


          • #6
            Originally posted by GHST View Post
            Same. Since the upgrade, there is no option to switch styles. The quickstyle is there but empty, you cannot change it. I also cannot use the mobile theme via my iPhone even though I have gone through and enabled the new version of the mobile theme.

            Help!
            Same here

            Comment


            • #7
              Originally posted by GHST View Post
              Same. Since the upgrade, there is no option to switch styles. The quickstyle is there but empty, you cannot change it. I also cannot use the mobile theme via my iPhone even though I have gone through and enabled the new version of the mobile theme.

              Help!
              Same here..

              When users connect with mobile they see the mobile skin. When change it to PC mode.. it changes to PC mode.. but they cant get back to mobile.
              Style chooser has no styles to choose from.. Let user change style is set to yes on every style.

              pse fix.

              Comment


              • #8
                same for me the quickstyle is empty and the forum blocks are now under the who is online block (they are normally at the right of the forum like this forum) i'm using the default style

                thanks

                Comment


                • #9
                  This is what my quick style chooser looks like now. Any ideas?

                  Click image for larger version

Name:	chooser.JPG
Views:	1
Size:	11.8 KB
ID:	3686818

                  Comment


                  • #10
                    Check your footer template to ensure it's actually been merged OK. You may need to revert it and reapply any customsations
                    Vote for:

                    - *Admin Settable Paid Subscription Reminder Timeframe*
                    -
                    *PM - Add ability to reply to originator only*
                    - Add Admin ability to auto-subscribe users to specific channel(s)
                    - "Quick Route" Interface...

                    Comment


                    • #11
                      Originally posted by Trevor Hannant View Post
                      Check your footer template to ensure it's actually been merged OK. You may need to revert it and reapply any customsations
                      Yup... That's what I thought. It's good now.

                      Thanks.

                      Comment


                      • #12
                        Footer

                        When I go into the foot template to try and fix the Quick Style Chooser and try to save the template I am getting this message:

                        Warning: Invalid argument supplied for foreach() in [path]/includes/functions.php on line 3561

                        The following Template-Modificatiosn could not be applied.
                        To make sure that the Template works correctly, you should either modify the Template or the Template-Modifications.

                        If the modifications are not important, you can also choose to ignore this warning.

                        Comment


                        • #13
                          Then you haven't made the change correctly. Try this:

                          - take a note of any customisations you have in the template
                          - revert the template
                          - re-apply your customisations
                          Vote for:

                          - *Admin Settable Paid Subscription Reminder Timeframe*
                          -
                          *PM - Add ability to reply to originator only*
                          - Add Admin ability to auto-subscribe users to specific channel(s)
                          - "Quick Route" Interface...

                          Comment


                          • #14
                            Ok, i found the fix.

                            Go into your footer template and edit it.

                            find:
                            Code:
                            <form action="{vb:link forumhome|nosession}" method="get" id="footer_select" class="footer_select">
                            
                            
                                    <vb:if condition="$show['quickchooser']">
                                        <select name="styleid" onchange="switch_id(this, 'style')">
                                            <optgroup label="{vb:rawphrase quick_style_chooser}">
                                                {vb:raw quickchooserbits}
                                            </optgroup>
                                        </select>    
                                    </vb:if>
                            
                                    <vb:if condition="$show['languagechooser']">
                                        <select name="langid" onchange="switch_id(this, 'lang')">
                                            <optgroup label="{vb:rawphrase quick_language_chooser}">
                                                {vb:raw languagechooserbits}
                                            </optgroup>
                                        </select>
                                    </vb:if>
                                </form>
                            and replace with:
                            Code:
                            <form action="{vb:link forumhome|nosession}" method="get" id="footer_select" class="footer_select">
                            
                                    <vb:if condition="$show['quickchooser']">
                                        <select name="styleid" onchange="switch_id(this, 'style')">
                                            <optgroup label="{vb:rawphrase quick_style_chooser}"><option class="hidden"></option></optgroup>
                                            <vb:if condition="$quickchooserbits1">
                                                <vb:if condition="$quickchooserbits2">
                                                <optgroup label="&nbsp;{vb:rawphrase standard_styles}">
                                                </vb:if>                
                                                {vb:raw quickchooserbits1}
                                                <vb:if condition="$quickchooserbits2">
                                                </optgroup>
                                                </vb:if>                    
                                            </vb:if>
                                            <vb:if condition="$quickchooserbits2">
                                                <vb:if condition="$quickchooserbits1">
                                                <optgroup label="&nbsp;{vb:rawphrase mobile_styles}">
                                                </vb:if>
                                                {vb:raw quickchooserbits2}
                                                <vb:if condition="$quickchooserbits1">
                                                </optgroup>
                                                </vb:if>                    
                                            </vb:if>
                                        </select>    
                                    </vb:if>
                            
                                    <vb:if condition="$show['languagechooser']">
                                        <select name="langid" onchange="switch_id(this, 'lang')">
                                            <optgroup label="{vb:rawphrase quick_language_chooser}">
                                                {vb:raw languagechooserbits}
                                            </optgroup>
                                        </select>
                                    </vb:if>
                                </form>
                            BMW M3 Enthusiast - m3fever.com
                            Gamer/Modder - stealthygaming.com

                            Comment


                            • #15
                              Originally posted by HowardE View Post
                              Yup... That's what I thought. It's good now.

                              Thanks.
                              How did you did it , with explanation to beginners pls.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X