Announcement

Collapse
No announcement yet.

Forum will not install

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Forum will not install

    Due to the following errors, the install/upgrade can not continue:
    • The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the includes/config.php file
    • Error description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (46)/includes/class_core.php on line 315
    Its driving me nuts. I have changed passwords, made and then deleted databases, made sure my " mysql has all the proper things, tried mysqli since I have a newer version, done everything the config.php suggested. And I am sure its some simple little thing I am doing wrong. Does anyone have experience with this issue?

    Oh and before the obvious question, I have the correct username and password for mysql nd had created a database vbforum but no help. Under the collation, it is not UTF8 across the board in the vbforum. the Mysql is UTF8 this is driving me absolutely nuts.

    Thank you
    Steve

    Steve

    Thank you in advance

  • #2
    Originally posted by steve340 View Post
    ...The database has failed to connect because you do not have permission to connect to the server.
    ...
    Does anyone have experience with this issue?
    Yes.

    Oh and before the obvious question, I have the correct username and password for mysql nd had created a database vbforum but no help.
    Perhaps the user does not have permission to use that database?
    Last edited by beishe8; Thu 16 Feb '12, 12:47am.


    vB5 is unequivocally the best forum software, but not yet...

    Comment


    • #3
      Hi Steve, try this script

      http://www.ardamis.com/2008/05/26/a-...se-connection/
      Owner: Oracle Forums - General Discussion Forums.

      Comment


      • #4
        Originally posted by beishe8 View Post
        Yes.


        Perhaps the user does not have permission to use that database?
        I thought of that. One thing about yahoo, is they like yroot. So I went in and changed permissions and added everything including table permissions. I then tried root, etc. To a degree, I am using my 3.7 config.php to get some hints. Becfause back then, they had more time to help I guess. And no help.

        I also ran server querys, and when you look at the stats, the mysql is getting tons of activity, just somethingt I am missing.

        Thank you

        Steve

        Comment


        • #5
          Here is another question, if your creating a database in mysql. it does not have and tables and such. If you do that, does vbulletin populate it as it sees fit? Also in one of the files, I read it uses the utf8, thats the collation for the mysql but some of the others are defaulted to the latin/swiss? one. Could this be a factor? I am just thinking out loud here. Maybe something will lead to a clue. I just deleted and recreated a new utf8 general database, Ill give that a whirl....

          thank you
          Steve

          Comment


          • #6
            Well that didnt work
            however heres the permissions
            yroot localhost global ALL PRIVILEGES Yes


            So it is obviously authorized Well time to go keep aircraft safe for humanity, then come home and rethink this, I will try the script, I think it will be helpful.

            S

            Comment


            • #7
              Originally posted by steve340 View Post
              if your creating a database in mysql. it does not have and tables and such. If you do that, does vbulletin populate it as it sees fit?
              Yes.


              vB5 is unequivocally the best forum software, but not yet...

              Comment


              • #8
                Solved !!!!!

                Originally posted by beishe8 View Post
                Yes.
                VERY Interesting. With some feedback from tech support, I renewed my scrutiny of the config.php file. I then compared it to my other board, and went line by line. Under Masterserver name it had 2 options, localhost or 127.0.0.1 or what ever. On my 3.7 board this was mysql, not localhost or an IP, so I changed that, and 15 minutes later, the install was done ! SO I took a new crash course in all of this, and a lot of help and ideas from you guys. I appreciate it a lot.

                Steve

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X