Announcement

Collapse
No announcement yet.

New Installation issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] New Installation issues

    I have set everything up as its suposed to be, and yet I get this error message

    Due to the following errors, the install/upgrade can not continue:
    • The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the includes/config.php file
    • Error description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (46)/forum/includes/class_core.php on line 315

    I set a password in the my php, and then put it in the config.php in the includes folder. Still no luck. Any suggestions
    Thanks in advance
    Steve

  • #2
    Originally posted by steve340 View Post
    I have set everything up as its suposed to be, and yet I get this error message

    Due to the following errors, the install/upgrade can not continue:
    • The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the includes/config.php file
    • Error description: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (46)/forum/includes/class_core.php on line 315
    I set a password in the my php, and then put it in the config.php in the includes folder. Still no luck. Any suggestions
    Thanks in advance
    Steve
    Does not connect to the database because the data entered are incorrect. You must enter data in red, if you don't know them, contact your service provider.

    PHP Code:
    //    ****** DATABASE NAME ******
        //    This is the name of the database where your vBulletin will be located.
        //    This must be created by your webhost.
    $config['Database']['dbname'] = 'name database';

    ****** 
    MASTER DATABASE SERVER NAME AND PORT ******
        
    //    This is the hostname or IP address and port of the database server.
        //    If you are unsure of what to put here, leave the default values.
        //
        //    Note: If you are using IIS 7+ and MySQL is on the same machine, you 
        //    need to use 127.0.0.1 instead of localhost
    $config['MasterServer']['servername'] = 'localhost';(make sure both localhost)
    $config['MasterServer']['port'] = 3306;


    //    ****** MASTER DATABASE USERNAME & PASSWORD ******
        //    This is the username and password you use to access MySQL.
        //    These must be obtained through your webhost.
    $config['MasterServer']['username'] = 'username database';
    $config['MasterServer']['password'] = 'password database'

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X