I am about to upgrade to 5.4.3 and think I have it ready to go. I am concerned about one thing: I'm not certain if I have the correct Customer ID as it was a few years ago that vBulletin was purchased....