Announcement

Collapse
No announcement yet.

Database error The database has encountered a problem.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • donald1234
    replied
    Good news having the wrong type of database is the same as having no database at all, hence the no database type error. The new server must be configured to run mysqli only while most will run either.

    Leave a comment:


  • Sergio68
    replied
    Hi Mark, as I said, I tried and that was the problem, I changed to "mysqli" and now it's working, please have a look : http://test.bodyweb.com

    Leave a comment:


  • Mark.B
    replied
    That won't matter, it's only deprecated, not removed. Besides you can just specifiy mysqli instead, in the config.php file.

    We need the database error though...raising a support ticket isn't going to get round that.You need to do two things:

    1. Run php 5.4 not php 5.5 - we are not going to be able to get vB4 to work on php 5.5 for you, it has not been certified.
    2. Obtain the actual database error...it will be a MySQL error. Your hosts should be able to help with this, if the forum has not emailed it to you. If you're logged in as an admin you can also try Right Click > View Source on the error.

    Leave a comment:


  • Sergio68
    replied
    In the config.php files I just need to change "mysql" with "mysqli".

    PHP Code:
     $config['Database']['dbtype'] = 'mysqli'
    "Solved"....may be.

    Leave a comment:


  • Sergio68
    replied
    OMG http://php.net/function.mysql-connect

    Leave a comment:


  • Sergio68
    replied
    That's bad because I need to RUN a Magento store with OptCache from the new 5.5 PHP. Since now I've a test.bodyweb.com website I'll try to fix the mysql error first then see what can be done.
    I'm still waiting for the password to enter into the members zone. Do you think the password recovery system is suspended for the holiday?

    Leave a comment:


  • Mark.B
    replied
    We still don't know the actual database error that is behind all this. Until we see that, it's difficult to advise.

    However in the first instance you need to be running php 5.4, not 5.5. vB4.2.2 is not certified for php 5.5 at this time.

    Leave a comment:


  • Sergio68
    replied
    I will submit a ticket as soon as they send me the password that I forgot.
    Thank you very much for your time Donald, have a nice day.

    Leave a comment:


  • donald1234
    replied
    members.vbulletin.com

    Leave a comment:


  • Sergio68
    replied
    Holiday? I guess I'm out of luck, LOL.
    I didn't still have opened a ticket, I have no idea if I'm entitled to support, I'm a licensed customer, I hope I can
    Do you know where I can do?

    Leave a comment:


  • donald1234
    replied
    I am out of ideas you will need to wait for support to respond, unfotunately it's a holiday in US today. Do you have ticket support?

    Leave a comment:


  • Sergio68
    replied
    mysqld (pid 27897) is running...

    Already checked that too

    Leave a comment:


  • donald1234
    replied
    What does it say following this command?

    Code:
    /etc/init.d/mysqld status

    Leave a comment:


  • Sergio68
    replied
    Donald, we did that exact two things already, please check couple post over

    Leave a comment:


  • donald1234
    replied
    If that doesn't work look at the error log here
    Code:
    [B]/var/log/mysqld.log[/B]

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X