Announcement

Collapse
No announcement yet.

Strange behavior with my vbulletin 4 CMS installation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Strange behavior with my vbulletin 4 CMS installation

    For long time I had vbulletin 4.1.7 installed on a virtual Apache server. There were no problems. But suddently one day my server crashed. I restartet and for an hour it all was good again. Then it crashed again.

    I have done nothing with the installation. My daily visitor count is falling, so it cant' be an overload issue from visitors.

    From SSH with TOP command, my server looks this, when its running good:

    Code:
    top - 00:04:03 up 3 min,  1 user,  load average: 0.46, 0.50, 0.22
    Tasks:  76 total,  1 running,  75 sleeping,  0 stopped,  0 zombie
    Cpu(s):  2.0%us,  0.7%sy,  0.0%ni, 97.0%id,  0.3%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:  4060704k total,  311252k used,  3749452k free,    16444k buffers
    Swap:  270328k total,        0k used,  270328k free,    89164k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND          
    1769 www-data  20  0  280m  21m 4036 S  2.0  0.5  0:02.07 apache2            
    1108 mysql    20  0  179m  34m 7016 S  0.3  0.9  0:08.93 mysqld            
    1846 jimmy    20  0 19120 1284  988 R  0.3  0.0  0:00.07 top                
        1 root      20  0 19316 1620 1184 S  0.0  0.0  0:03.39 init              
        2 root      15  -5    0    0    0 S  0.0  0.0  0:00.13 kthreadd          
        3 root      RT  -5    0    0    0 S  0.0  0.0  0:00.00 migration/0        
        4 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 ksoftirqd/0        
        5 root      RT  -5    0    0    0 S  0.0  0.0  0:00.00 watchdog/0        
        6 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 events/0          
        7 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 cpuset            
        8 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 khelper            
        9 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 netns              
      10 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 async/mgr          
      11 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 kintegrityd/0      
      12 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 kblockd/0          
      13 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 kacpid            
      14 root      15  -5    0    0    0 S  0.0  0.0  0:00.00 kacpi_notify
    And this is how it looks, just before I have to restart:


    Code:
    top - 23:52:05 up  9:45,  1 user,  load average: 102.12, 96.38, 71.83
    Tasks: 235 total, 100 running, 135 sleeping,  0 stopped,  0 zombie
    Cpu(s): 18.5%us, 81.5%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:  4060704k total,  3154876k used,  905828k free,  114012k buffers
    Swap:  270328k total,        0k used,  270328k free,  241140k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND          
    4787 www-data  20  0  224m  30m 3032 R  1.7  0.8  0:14.04 apache2            
    4915 www-data  20  0  213m  19m 2984 R  1.7  0.5  0:04.64 apache2            
    1037 mysql    20  0  340m  78m 7328 S  1.3  2.0  4:02.62 mysqld            
    4596 www-data  20  0  214m  18m 4900 R  1.3  0.5  0:28.31 apache2            
    4643 www-data  20  0  212m  18m 3340 R  1.3  0.5  0:27.62 apache2            
    4678 www-data  20  0  222m  28m 3268 R  1.3  0.7  0:27.40 apache2            
    4715 www-data  20  0  212m  19m 3344 R  1.3  0.5  0:25.40 apache2            
    4729 www-data  20  0  227m  33m 3340 R  1.3  0.8  0:22.72 apache2            
    4747 www-data  20  0  227m  33m 3300 R  1.3  0.9  0:19.84 apache2            
    4753 www-data  20  0  219m  25m 3236 R  1.3  0.7  0:18.88 apache2            
    4756 www-data  20  0  226m  33m 3644 R  1.3  0.8  0:19.23 apache2            
    4760 www-data  20  0  226m  33m 3220 R  1.3  0.8  0:15.52 apache2            
    4770 www-data  20  0  223m  30m 3528 R  1.3  0.8  0:15.52 apache2            
    4776 www-data  20  0  222m  29m 3232 R  1.3  0.7  0:15.60 apache2            
    4783 www-data  20  0  220m  27m 3240 R  1.3  0.7  0:15.27 apache2            
    4792 www-data  20  0  212m  19m 3588 R  1.3  0.5  0:13.15 apache2            
    4831 www-data  20  0  220m  26m 3008 R  1.3  0.7  0:08.60 apache2
    Since this problem started, I did a update to vbulletin 4.1.10, but the problem is the same. Maybe i located the problem to the CMS mod, because i have found out, the everytime someone posts ind the CMS, my server crash. I have been running some debugging and i can see that the CMS is doing a lot more queries, than the rest of the site.

    Debug info from main page (CMS page).

    Code:
    • Page Generation 0.26125 seconds
    • Memory Usage 27,104KB
    • Queries Executed 141 (?)
    And this is debug info from the forum main page:

    Code:
    Page Generation 0.19257 seconds
    Memory Usage 15,924KB
    Queries Executed 30 (?)
    What can the problem be, and how to solve it? PLEASE HELP!

    /Jimmy
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X