Announcement

Collapse
No announcement yet.

Facebook Connect button broken?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Facebook Connect button broken?

    When I click the Facebook connect icon on my forum, nothing happens. I don't even see the browser attempting to contact an address. I've tried in Firefox and Chrome, and made sure that the facebook plugin setup is done properly via the guide in the manual.

    Anyone have ideas why the button is unresponsive?

  • #2
    If you're using a version of vBulletin below 4.1.8, you will either need to upgrade to support OAuth2 or contact Facebook to have them downgrade you to the older javascript authorization method.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      is there any guide to do so ?
      VOTE ->Allow to rotate and tag the album pictures
      ~~~~~~~~~~~~~~~~~~~~~~~
      Official vbulletin Italian Group on vbulletin.com, Join us HERE
      ~~~~~~~~~~~~~~~~~~~~~~~
      Helping people to settle in Australia:
      www.australianboard.com
      The community of the people that dream Australia:
      www.australianboardcommunity.com

      Comment


      • #4
        Guide to upgrade? It is the same as upgrading to any other version.

        https://www.vbulletin.com/docs/html/upgrade
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          no, a guide to to upgrade to support OAuth2

          Anyway i found that the issue is not related to OAuth2

          https://www.vbulletin.com/forum/showthread.php/395053-Facebook-fconnect-does-not-work-complete-check-(it-will-help-a-lot)
          VOTE ->Allow to rotate and tag the album pictures
          ~~~~~~~~~~~~~~~~~~~~~~~
          Official vbulletin Italian Group on vbulletin.com, Join us HERE
          ~~~~~~~~~~~~~~~~~~~~~~~
          Helping people to settle in Australia:
          www.australianboard.com
          The community of the people that dream Australia:
          www.australianboardcommunity.com

          Comment


          • #6
            Originally posted by valerios View Post
            no, a guide to to upgrade to support OAuth2
            We don't provide partial upgrades or fixes for individual bugs.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              The FB Connect button isn't working on one of my forums as well. We're running 4.1.10, and I've checked the troubleshooting steps in valerios's thread, still no go.

              When hovering over the button, the browser status bar shows http://www.forumname.com/#
              ~ Life isn't always fair, but you can be. ~

              Comment


              • #8
                Originally posted by cbiweb View Post
                The FB Connect button isn't working on one of my forums as well. We're running 4.1.10, and I've checked the troubleshooting steps in valerios's thread, still no go.

                When hovering over the button, the browser status bar shows http://www.forumname.com/#
                That is exactly what it is supposed to show. Do you have any Javascript errors on your site?
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  Javascript checks out okay, but Firefox reports dozens of CSS errors, and in that list I found this message:

                  Error: uncaught exception: Error: Permission denied for <https://www.facebook.com> to get property Proxy.InstallTrigger
                  ~ Life isn't always fair, but you can be. ~

                  Comment


                  • #10
                    Originally posted by cbiweb View Post
                    Javascript checks out okay, but Firefox reports dozens of CSS errors, and in that list I found this message:

                    Error: uncaught exception: Error: Permission denied for <https://www.facebook.com> to get property Proxy.InstallTrigger
                    That is a Javascript error, not a CSS error. Make sure the URL on your Facebook App matches that people access your site from. It has to match exactly, down to the closing /.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud demonstration site.
                    vBulletin 5 API - Full / Mobile
                    Vote for your favorite feature requests and the bugs you want to see fixed.

                    Comment


                    • #11
                      I might be a little confused here, having been out of the loop for several months. You say "Facebook App", which I've heard of and assume it's something new, and not the same as the "Facebook Connect" button that was first introduced way back when. Looking at the .pdf instructions linked to in this thread, I see that there is an ACP settings group for "Facebook App Options", while I only have have settings in the ACP for "Facebook Options". Plus, in that thread Trevor says "those who have not yet purchased the product", which makes me think that this Facebook App is not the free FB Connect button I have.

                      Am I correct, or am I totally lost? lol
                      ~ Life isn't always fair, but you can be. ~

                      Comment


                      • #12
                        I'll submit a support ticket.
                        ~ Life isn't always fair, but you can be. ~

                        Comment


                        • #13
                          I have same problem
                          i stoped all MOD's from includes/config.php and now working

                          try to do that and check it

                          i think there are an code java conflicted with the fb button in any mod

                          Comment


                          • #14
                            That was one of the first things I tried, but thanks for the suggestion.
                            ~ Life isn't always fair, but you can be. ~

                            Comment


                            • #15
                              Originally posted by cbiweb View Post
                              That was one of the first things I tried, but thanks for the suggestion.
                              Welcome
                              and ??

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X