Announcement

Collapse
No announcement yet.

Logged in, but displaying login information

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Joe D.
    replied
    I force WWW with this in my .htaccess file:

    Code:
    RewriteEngine on
    RewriteCond %{HTTP_HOST} !^www.your_domain.com$
    RewriteRule ^(.*)$ http://www.your_domain.com/$1 [R=301]
    If that doesn't work make sure .htaccess is in your web root (not always the same as your forum root)

    If it still doesn't work, make you you are using a web server that uses .htaccess files (as in NOT windows IIS)

    Leave a comment:


  • Brandon Perkins
    replied
    its setup http://www.mysite.com/forum

    Leave a comment:


  • gezuvor
    replied
    How is your forum URL set in AdminCP / Options / Site Name page?? I had this same problem and realized my settings and my htaccess were fighting each other and vB didn't like it...

    Leave a comment:


  • Logged in, but displaying login information

    Im not sure if my users are experiencing this, but I am.

    i Log in at the top of the page, and it says logged in, redirecting. Then when it redirects you, it displays the Login query at the top again. If i click forum, I am actually logged in. Its like its not detecting im logged in at the login/logout bar

    What's causing this ?


    Edit:

    Okay it seems ive figured the problem out. I was typing my url without the www in the address bar.

    how can I force the WWW and also redirect the forum? Right now i have

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^(www.)?mywebsite.com$
    RewriteRule ^(/)?$ forum [L]

    What i need to do is force the WWW into the domain, so if you type mywebsite.com, it shows up www.mywebsite.com/forum. right now you type mywebsite.com and it shows up mywebsite.com/forum which isnt working right
    Last edited by Brandon Perkins; Sat 21 Jan '12, 4:05pm.

Related Topics

Collapse

Working...
X