Announcement

Collapse
No announcement yet.

@Font-Face function is not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lynne
    replied
    I cannot find anywhere on the page where the font is being applied. If I apply it via firefox, it seems to work.

    Leave a comment:


  • Wayne Luke
    replied
    You shouldn't be looking at the css.php call. You need to be looking at the generated CSS in the right pane to find the class of the item. Then you can match that class to a stylevar.

    This video explains it: https://www.vbulletin.com/forum/cont...deo-version%29

    Leave a comment:


  • stator
    replied
    hi guys

    I feel as I am orphan in this forum, please anyone help

    Leave a comment:


  • stator
    replied
    The css path is

    Code:
    /css.php?styleid=6&langid=1&d=1326198256&td=ltr&sheet=forumbits.css,forumhome.css,widgets.css,sidebar.css,options.css,tagcloud.css
    I cannot figure out which one

    Leave a comment:


  • stator
    replied
    I am using Firebug to know corresponding stylevar but i lost

    Leave a comment:


  • stator
    replied
    Originally posted by Wayne Luke View Post

    Finally, after you add the font family, did you edit the stylevars to include the Harabara family in the different font definitions?
    Thanks all for your response,

    Actually I've tried it with copyright font & found it is working, but not working with pagetitle, therefore; I suspect that I changed the wrong StyleVar.

    Therefore; I attach the font I want to change to guide me which stylevar to change. Click image for larger version

Name:	pagetitle.jpg
Views:	1
Size:	54.8 KB
ID:	3686409
    Thanks in Advance.

    Leave a comment:


  • LisaArnold
    replied
    Hi stator,

    You might find your answer in my thread where I was also having issues with @font face. Hope it helps you.

    https://www.vbulletin.com/forum/show...-vBulletin-4-0

    Leave a comment:


  • Wayne Luke
    replied
    @font-face works in all browsers to different degrees. It has worked in IE since version 5.

    What are the contents of the harabara.css file?

    Also urls in a CSS file are relative to the CSS file, not the file calling it. Are you storing CSS files in the file system? If so, then you'll want to use absolute URLs to load your fonts. If you're not worried about loading files from an off-site server you can always use the Google Web Fonts code to include it.

    Finally, after you add the font family, did you edit the stylevars to include the Harabara family in the different font definitions?

    Leave a comment:


  • Joe D.
    replied
    What browser are you using? @Font-face doesn't work in IE I think.

    Leave a comment:


  • stator
    replied
    Hello guys

    I see other newer threads replied & mine is not.

    Leave a comment:


  • stator
    started a topic [Forum] @Font-Face function is not working

    @Font-Face function is not working

    My site: www.elib4vet.com

    I want to apply new font for page title.

    I added to headinclude template the following line at the begining:

    Code:
    <link href='css/harabara.css' rel='stylesheet'  type='text/css'>
    Then I went to: Style Variable Editor - vB4 Default Style >> Common >> pagetitle_font >> Font Family >> HarabaraRegular

    I also added to additional.css the following:

    Code:
    @font-face {
        font-family: 'Harabara';
        src: url('fonts/harabara/harabara-webfont.eot');
        src: url('fonts/harabara/harabara-webfont.eot?#iefix') format('embedded-opentype'),
             url('fonts/harabara/harabara-webfont.woff') format('woff'),
             url('fonts/harabara/harabara-webfont.ttf') format('truetype'),
             url('fonts/harabara/harabara-webfont.svg#HarabaraRegular') format('svg');
        font-weight: normal;
        font-style: normal;
    
    }
    However nothing changed
    Last edited by stator; Sun 8th Jan '12, 4:41am.

Related Topics

Collapse

Working...
X