Announcement

Collapse
No announcement yet.

trying to add a horizontal menu

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] trying to add a horizontal menu

    Hi. I have been trying to add a horizontal menu using the various ad location templates in style manager. The problem is it ends up crowding the login area on the top right of the page. I then decided to add the menu code to the index.php to have it appear above the login area....this worked great at least until I tried it in IE where I got a blank page. I need help to wrap this code so is does not crowd the login area or to add it to the index.php without getting a white page.

    I have included a link to a real time text editor as it enables making adjustments without needing to refresh page...but anyway as mentioned the code is fine...I just need to make it work in vb.
    http://htmledit.squarefree.com/

    <html>
    <head>
    <title></title>
    </head>
    <body>


    <style type="text/css">


    #menu {
    width:100%;
    height:40px;
    background-color:#0A4A7A;
    }


    #menu ul {
    width:80%;
    margin:0 auto 0 auto;
    }


    #menu ul li {
    float:left;
    color:#CC0000;
    padding:0 20px 0 20px;
    border-right:1px solid #FFF;
    border-left:1px solid #FFF;
    height:40px;
    list-style:none;
    display:block;
    line-height:30px;
    text-align:center;
    cursorointer;
    }


    #menu ul li:hover {
    background-color:#ccc;
    }


    </style>
    <div id="menu">


    <ul>
    <li><font size=2><b><a href="http://www.yourwebsite.com.com/?view=selectcity&targetview=post&cityid=0&lang=en"><font color=white>POST AN AD</a>
    <li><a href="http://www.yourwebsite.com.com/"><font color=white>CLASSIFIEDS</a>
    <li><a href="http://www.yourwebsite.com.com/forum"><font color=white>FORUM</a>

    <li><a href="http://www.yourwebsite.com.com/elgg"><font color=white>COMMUNITY</a>
    <li><a href="http://www.yourwebsite.com.com/elgg/pg/photos/world/"><font color=white>PHOTO ALBUMS</a>
    <li><a href="http://www.yourwebsite.com-webcams.com"><font color=red>MISC</font></a>
    </ul>


    </div>
    </body>
    </html>
    Last edited by scorpio24; Mon 2nd Jan '12, 8:09am.

  • #2
    You cannot go add that exact code to a vbulletin template, or into an ad. You page will not like having two <html>, <head>, or <body> tags - that is not permitted.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools &lt;- awesome site for html/css help

    Comment


    • #3
      Yes I tried it without the tags...but still a white page. I have placed in two other platforms and have no issues. Any suggestions?

      Comment


      • #4
        How did you go about adding it to index.php? Do you mean you literally added it to the php file? You cannot do that. You would need to add it (only the code in the body, not any tags) to a template. Did you try that? Which *exact* template did you add it to and what is the *exact* code you tried to add?

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools &lt;- awesome site for html/css help

        Comment


        • #5
          Originally posted by Lynne View Post
          How did you go about adding it to index.php? Do you mean you literally added it to the php file? You cannot do that. You would need to add it (only the code in the body, not any tags) to a template. Did you try that? Which *exact* template did you add it to and what is the *exact* code you tried to add?
          ad_header_logo
          ad_global_header1
          ad_globlal_header2

          <style type="text/css">


          #menu {
          width:100%;
          height:40px;
          background-color:#0A4A7A;
          }


          #menu ul {
          width:80%;
          margin:0 auto 0 auto;
          }


          #menu ul li {
          float:left;
          color:#CC0000;
          padding:0 20px 0 20px;
          border-right:1px solid #FFF;
          border-left:1px solid #FFF;
          height:40px;
          list-style:none;
          display:block;
          line-height:30px;
          text-align:center;
          cursorointer;
          }


          #menu ul li:hover {
          background-color:#ccc;
          }


          </style>
          <div id="menu">


          <ul>
          <li><font size=2><b><a href="http://www.yourwebsite.com.com/?view=selectcity&targetview=post&cityid=0&lang=en"><font color=white>POST AN AD</a>
          <li><a href="http://www.yourwebsite.com.com/"><font color=white>CLASSIFIEDS</a>
          <li><a href="http://www.yourwebsite.com.com/forum"><font color=white>FORUM</a>

          <li><a href="http://www.yourwebsite.com.com/elgg"><font color=white>COMMUNITY</a>
          <li><a href="http://www.yourwebsite.com.com/elgg/pg/photos/world/"><font color=white>PHOTO ALBUMS</a>
          <li><a href="http://www.yourwebsite.com-webcams.com"><font color=red>MISC</font></a>
          </ul>


          </div>

          I would like it to be above the level of the login area if possible which is why I tried the index.php file because I don't think that is a vb template option.. I just pasted it as is in both the templates and at the beginning of the index.php file.

          Comment


          • #6
            Nevermind...I managed to get it to work in ad_header_logo minus the tags like above...I was sure I tried that before but anyway now all is good. Thanks for the help.
            Last edited by scorpio24; Mon 2nd Jan '12, 6:58pm.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X