Announcement

Collapse
No announcement yet.

"Too many connections" error all day yesterday

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] "Too many connections" error all day yesterday

    The day before last I'd been getting the typical mySQL, core.php errors I do every time the hosting solution temporarily goes down, but yesterday, it was different...

    Yesterday every hour for the whole 24 hours, I got a pair of "too many connections" errors that filled my mailbox - what's going on!?

    I currently have version 4.0.5 but plan to update to the latest version, as well as Spam-O-Matic 2.0.2.
    Tiletron/Hyncharas/Arandra:= Simon Spencer | Portfolio Gallery:= http://tiletron.deviantart.com
    Projects:= Stargate: Horizon, Stargate: Andromeda (Production Designer, Technical Writer)

    Online:= Stargate-Universe (Staff) | Clan Draconus Lupus (Black Dragonwolf)

  • #2
    "Too many connections" error all day yesterday

    Getting something like this? This one is from my forum. I am confused as well and would like any help in trouble shooting this.

    Database error in vBulletin :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: User huskerma_redmax already has more than 'max_user_connections' active connections
    /home/huskerma/public_html/vbbs/includes/class_core.php on line 314

    MySQL Error :
    Error Number :
    Request Date : Tuesday, December 20th 2011 @ 05:33:35 PM
    Error Date : Tuesday, December 20th 2011 @ 05:33:35 PM
    Script : http://www.huskermax.com/vbbs/content.php?187-HUSKER-DAN-S-2011-BOWL-GAME-SPECIAL
    Referrer : http://huskermax.com/
    IP Address : 70.58.63.57
    Username :
    Classname : vB_Database
    MySQL Version :

    Comment


    • #3
      MSN boot?

      Have you check the email you get who is crawl your forum? I was down many time because of the MSN boot but i now but a robot text on it and it works better but not perfect. Another issue is the spam problem and they many spams that come to your forum. Blocking a country like Pakistan might help you forum a great deal.

      Comment


      • #4
        &amp;quot;Too many connections&amp;quot; error all day yesterday

        I am not sure were to go to find out which bots are crawling or were the spam is coming from.

        I get a lot of spam in my comments on my articles.

        Comment


        • #5
          You not get an email i get something like this.

          Database error in vBulletin :

          mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections
          /home/personal/public_html/includes/class_core.php on line 314

          MySQL Error :
          Error Number :

          Request Date : Tuesday, December 20th 2011 @ 12:42:22 AM
          Error Date : Tuesday, December 20th 2011 @ 12:42:22 AM
          Script : my domain
          Referrer :
          IP Address : 87.250.253.243

          i check the ip with https://ipdb.a and you see what robots they are.

          Comment


          • #6
            Yea, I get that, did a search on the ip of the one I listed above and it looks like it is not spam. My guess is a server connections has nothing to do with vBulletin so I need to contact the server company?

            Comment


            • #7
              I've been having problems with getting those messages for the past week and it turned out to be beta db_governor on the server that was causing the issue. Once turned off these issues stopped.

              Comment


              • #8
                My issue is the shared hosting i am using. What is the beta db_governor?

                Comment


                • #9
                  Originally posted by mindstream View Post
                  My issue is the shared hosting i am using. What is the beta db_governor?
                  Sorry no idea what it is, I'm on shared hosting too and that's what I was told was the cause of me getting the errors.

                  Comment


                  • #10
                    Now I'm also getting this:

                    "Lost connection to MySQL server at 'reading initial communication packet', system error: 111"

                    I haven't received any further connection errors since Tuesday, though my forums do still seem to be working although are intermittent. Could it be a problem with the server-hosts rather than the forum itself?
                    Tiletron/Hyncharas/Arandra:= Simon Spencer | Portfolio Gallery:= http://tiletron.deviantart.com
                    Projects:= Stargate: Horizon, Stargate: Andromeda (Production Designer, Technical Writer)

                    Online:= Stargate-Universe (Staff) | Clan Draconus Lupus (Black Dragonwolf)

                    Comment


                    • #11
                      Now another error! This is even more confusing:

                      Invalid SQL:
                      SELECT node.nodeid AS itemid, parent.nodeid, parent.url, parent.styleid, parent.layoutid, parent.publishdate,
                      parent.setpublish, parent.hidden, info.title, info.description

                      FROM cms_node AS node
                      INNER JOIN cms_node AS parent ON (node.nodeleft >= parent.nodeleft AND node.nodeleft <= parent.noderight)
                      INNER JOIN cms_nodeinfo AS info ON info.nodeid = parent.nodeid
                      LEFT JOIN cms_sectionorder AS ord ON ord.nodeid = node.nodeid AND ord.sectionid = node.parentnode
                      WHERE node.nodeid IN (1)
                      AND parent.nodeid != node.nodeid

                      ORDER BY parent.nodeleft, ord.displayorder;
                      MySQL Error : Can't create/write to file '/tmp/#sql_38d6_0.MYI' (Errcode: 30)


                      I don't have the faintest idea about coding in SQL and simply followed the instructions when it came to installation. There's never been so many problems like this at once on the forums.
                      Tiletron/Hyncharas/Arandra:= Simon Spencer | Portfolio Gallery:= http://tiletron.deviantart.com
                      Projects:= Stargate: Horizon, Stargate: Andromeda (Production Designer, Technical Writer)

                      Online:= Stargate-Universe (Staff) | Clan Draconus Lupus (Black Dragonwolf)

                      Comment


                      • #12
                        Originally posted by Tiletron View Post
                        The day before last I'd been getting the typical mySQL, core.php errors I do every time the hosting solution temporarily goes down, but yesterday, it was different...

                        Yesterday every hour for the whole 24 hours, I got a pair of "too many connections" errors that filled my mailbox - what's going on!?

                        I currently have version 4.0.5 but plan to update to the latest version, as well as Spam-O-Matic 2.0.2.
                        Originally posted by Tiletron View Post
                        Now I'm also getting this:

                        "Lost connection to MySQL server at 'reading initial communication packet', system error: 111"

                        I haven't received any further connection errors since Tuesday, though my forums do still seem to be working although are intermittent. Could it be a problem with the server-hosts rather than the forum itself?
                        Contact your host, this is a problem with them, not vBulletin.


                        Originally posted by mindstream View Post
                        You not get an email i get something like this.

                        Database error in vBulletin :

                        mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Too many connections
                        /home/personal/public_html/includes/class_core.php on line 314

                        MySQL Error :
                        Error Number :

                        Request Date : Tuesday, December 20th 2011 @ 12:42:22 AM
                        Error Date : Tuesday, December 20th 2011 @ 12:42:22 AM
                        Script : my domain
                        Referrer :
                        IP Address : 87.250.253.243

                        i check the ip with https://ipdb.a and you see what robots they are.
                        You too.
                        - Maurice Workin' in the Jira mine, goin' down, down, down

                        Comment


                        • #13
                          I already contact my host they since i am on a shared server it is my problem.

                          Comment


                          • #14
                            Originally posted by mindstream View Post
                            I already contact my host they since i am on a shared server it is my problem.
                            Sounds like you need a new host- your message inparticular was likely the result of low disk space on the mysql server/drive. A good host would never tell you that.

                            Comment


                            • #15
                              So hostgator is not a good host when it comes to Vbulletin?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X