Announcement

Collapse
No announcement yet.

After update WYSIWYG not work.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] After update WYSIWYG not work.

    Hello everyone.
    Recently I had patched my vBulletin installation from 4.1.7 to 4.1.9 and find myself with Enchanced WYSIWYG editor broken.
    Searched this forum for solution, read all topics found by keyword WYSIWYG or CKEditor and none of the solutions helped me.

    Admin CP > Options > Style & Language Settings
    Default Style for Old Mobile Browsers set to None
    Default Style for Modern Mobile Browsers set to None

    Tried to disable all plugins (while have only one, Post Thanks) both inside control panel and inside config.php. Didn't help.

    Reupload all files several times, md5 match, date and size match etc.

    Admin CP > Diagnostics > Suspect File Versions
    Shows nothing except few File not recognized as part of vBulletin for files like robots.txt etc.

    I don't use anything like cloudflare

    Browser or web server cache not the problem too.

    Admin CP > Options > Message Posting Interface Options
    Enable Standart & WYSIWYG Controls selected, same for corresponding option in user settings

    Not work in all browsers for all users

    No server errors like 404, 403, 500 when loading page, js, css, img


    No errors in JS console

    Tested on custom skin BlueSteel for 4.1.8 and on default skin for 4.1.9

    Is there something else what I can check? I even tried to debug work of scripts in FireBug, but with minimized scripts can't do a lot, even cant insert some alert() without headache.
    Last edited by XSu; Sat 17 Dec '11, 12:20pm.

  • #2
    Here also no remedy found for this.

    Comment


    • #3
      Please give more detail about how the WYSIWYG is not working...

      Example... "I wanted to do this but the WYSIWYG editor did this instead."

      Comment


      • #4
        We need more info as was asked, what exactly isn't working? A screenshot may help too. Also a link to your forum with a test username/password so we can see the editor would be best.

        Comment


        • #5
          i have also got same problem one day ago atlast i found there is an htaccess file in my ckediter folder which was restricting so delete it and it start working

          Comment


          • #6
            There is no way that htaccess in particular is restricting anything. Here is what is in it.
            Code:
            #
            # Copyright (c) 2003-2010, CKSource - Frederico Knabben. All rights reserved.
            # For licensing, see LICENSE.html or http://ckeditor.com/license
            #
            
            #
            # On some specific Linux installations you could face problems with Firefox.
            # It could give you errors when loading the editor saying that some illegal
            # characters were found (three strange chars in the beginning of the file).
            # This could happen if you map the .js or .css files to PHP, for example.
            #
            # Those characters are the Byte Order Mask (BOM) of the Unicode encoded files.
            # All FCKeditor files are Unicode encoded.
            #
            
            #AddType application/x-javascript .js
            #AddType text/css .css
            
            #
            # If PHP is mapped to handle XML files, you could have some issues. The
            # following will disable it.
            #
            
            #AddType text/xml .xml
            Originally posted by dotsis1 View Post
            i have also got same problem one day ago atlast i found there is an htaccess file in my ckediter folder which was restricting so delete it and it start working

            Comment


            • #7
              i dont know but it worked for me like a charm ,when i deleted that htaccess file my editer was back

              Comment


              • #8
                Sorry for delayed answer, celebrated New Year
                CKEditor doesn't display BB toolbar and don't parse new lines in "Enable Standard & WYSIWYG Controls", so all that weeks I use "Enable Standard Controls" to at least parse new lines.
                Attached Files

                Comment


                • #9
                  Just figured out what toolbar doesn't work only over HTTPS links. If I reopen any link via HTTP I see toolbar. Anyone can suggest why?

                  Comment


                  • #10
                    Found and "hacked" my problem.
                    Seems after patch from 4.1.7 PL2 to 4.1.9 whole AJAX didn't worked because of "var AJAXBASEURL" was set to HTTP scheme, while all requests are made under HTTPS.
                    Wrong scheme selected because vBulletin works in conjunction of nginx frontend and apache backend, where all internal communication is over HTTP without SSL. As a result mod_php receive HTTP scheme from apache.

                    To solve my issue I used dirty hack:
                    Changed /includes/class_core.php Line 2194
                    From
                    Code:
                    define('VB_URL_SCHEME',      $url_info['scheme']);
                    To
                    Code:
                    define('VB_URL_SCHEME',      'https');
                    While all was ok in previous versions I think this issue is somehow linked with vbulletin security system, something like anti-xss or anti-csrf filter. Please fix this issue or allow to force scheme/url in config so I dont need to make such dirty hacks.
                    Last edited by XSu; Wed 4 Jan '12, 11:21am.

                    Comment


                    • #11
                      Originally posted by XSu View Post
                      Found and "hacked" my problem.
                      Seems after patch from 4.1.7 PL2 to 4.1.9 whole AJAX didn't worked because of "var AJAXBASEURL" was set to HTTP scheme, while all requests are made under HTTPS.
                      Wrong scheme selected because vBulletin works in conjunction of nginx frontend and apache backend, where all internal communication is over HTTP without SSL. As a result mod_php receive HTTP scheme from apache.

                      To solve my issue I used dirty hack:
                      Changed /includes/class_core.php Line 2194
                      From
                      Code:
                      define('VB_URL_SCHEME',      $url_info['scheme']);
                      To
                      Code:
                      define('VB_URL_SCHEME',      'https');
                      While all was ok in previous versions I think this issue is somehow linked with vbulletin security system, something like anti-xss or anti-csrf filter. Please fix this issue or allow to force scheme/url in config so I dont need to make such dirty hacks.
                      I have the same problem with you
                      I use nginx reverse proxy with apache, vbulletin 4.1.10

                      follow your instructions
                      Changed /includes/class_core.php Line 2194
                      From
                      define('VB_URL_SCHEME', $url_info['scheme']);
                      To
                      define('VB_URL_SCHEME', 'https');
                      WYSIWYG is not working ;(

                      help me

                      Comment


                      • #12
                        I upgraded a forum today from 3.8.3 to 4.1.10, and there is no WYSIWYG, and no smilies. I can manually type bbcode, but there are no editing controls or buttons whatsoever. I tried almost everything mentioned in the OP, but no go. Does anyone know what to do?
                        ~ Life isn't always fair, but you can be. ~

                        Comment


                        • #13
                          Found a solution that worked for me in the Messed up Editor/Avatars/Other visual glitches after upgrade? thread.
                          ~ Life isn't always fair, but you can be. ~

                          Comment


                          • #14
                            Didn't fix it for me, nor do all the other suggestions posted in about a dozen thread I walked through. My forums work fine, but CMS does not. My articles don't show any formatting, and even entering them manually by typing out the BB Code, it doesn't work.

                            Comment


                            • #15
                              Originally posted by XSu View Post
                              Found and "hacked" my problem.
                              Seems after patch from 4.1.7 PL2 to 4.1.9 whole AJAX didn't worked because of "var AJAXBASEURL" was set to HTTP scheme, while all requests are made under HTTPS.
                              Wrong scheme selected because vBulletin works in conjunction of nginx frontend and apache backend, where all internal communication is over HTTP without SSL. As a result mod_php receive HTTP scheme from apache.

                              To solve my issue I used dirty hack:
                              Changed /includes/class_core.php Line 2194
                              From
                              Code:
                              define('VB_URL_SCHEME',      $url_info['scheme']);
                              To
                              Code:
                              define('VB_URL_SCHEME',      'https');
                              While all was ok in previous versions I think this issue is somehow linked with vbulletin security system, something like anti-xss or anti-csrf filter. Please fix this issue or allow to force scheme/url in config so I dont need to make such dirty hacks.
                              im working with nginx and fpm-php as backend vb is 4.1.10.
                              have exacly same problem. AJAXBASEURL was http, while site on https. so i folowed ur solution but made a lese hacky way, same file, /includes/class_core.php, but line 2088, i set it to

                              $scheme = ((':443' == $port) or ($_SERVER['SERVER_PORT'] ==443) OR (isset($_SERVER['HTTPS']) AND $_SERVER['HTTPS'] AND ($_SERVER['HTTPS'] != 'off'))) ? 'https://' : 'http://';
                              just in case if we go back to http.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X