Announcement

Collapse
No announcement yet.

fixed layout

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] fixed layout

    Hi,

    When I use the method for a fixed layout https://www.vbulletin.com/forum/cont...Style-Template

    I do get a centered, fixed width layout but when I switch from home to forum on tabs the layout shifts a bit to the left, then a bit to the right for example:

    I start on 'Home', when I click 'Forum', the whole layout shifts to the right, stays the same when I click 'Blogs', then when i click 'What's New' it shifts back to the left.

    Surely it's not supposed to be like that?

  • #2
    What do you have set for your doc_margin stylevar? The left and right options should both be set to auto.

    Have you set any other margins? You can view this by typing margin in the search box and selecting the box to show only edited stylevars.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      units: px
      use top val for all sides: no
      t:0
      r:auto
      b:0
      l:auto

      I made the doc width 1100 px, and have tried messing around with max width and min width, I reset them all and tried one at a time etc etc.

      It's a fresh install this is the first thing I tried to change, I have touched nothing else.

      Comment


      • #4
        Can we get a link to see this happen? Also, have you tried it in different browsers and does it happen in them all?

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to vbulletin.org
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help

        Comment


        • #5
          Hi,

          Yea I tried in IE8 and Chrome.

          It's on localhost xampp sorry I should have said that, but I really didn't think that could be the issue.

          I can give you screenshots but it really is just how I explain, when I move from Home to Forum the whole layout shifts about half a centimetre to the left, clicking on Blog stays stationary but then What's New moves it back, it's almost like Home and what's new has a slightly different auto effect to forum and blog.

          Comment


          • #6
            Originally posted by aaronater View Post
            Hi,

            Yea I tried in IE8 and Chrome.

            It's on localhost xampp sorry I should have said that, but I really didn't think that could be the issue.

            I can give you screenshots but it really is just how I explain, when I move from Home to Forum the whole layout shifts about half a centimetre to the left, clicking on Blog stays stationary but then What's New moves it back, it's almost like Home and what's new has a slightly different auto effect to forum and blog.
            More likely something about your layout makes the forum and blog wider than your layout allows. Auto is always calculated by the browser, though different browsers can treat the box model differently which affects margins.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              Does you have your browser wide enough? (So it's not adding a scroll bar). Also, just as an aside, 1100px is pretty wide. Not everyone is going to open their browsers that wide. I just checked the width of my browser window, and it's at about 950px. I never set it to fill the whole screen because I always have a couple of windows open at a time.

              Please don't PM or VM me for support - I only help out in the threads.
              vBulletin Manual & vBulletin 4.0 Code Documentation (API)
              Want help modifying your vbulletin forum? Head on over to vbulletin.org
              If I post CSS and you don't know where it goes, throw it into the additional.css template.

              W3Schools <- awesome site for html/css help

              Comment


              • #8
                1100px isn't that wide, i have a 14inch laptop and it's smaller than fluid layout appears (like vbulletin.com)

                Are you saying that if you make a fresh install of vb4 suite, (just to be thorough without cms default data) then only do 1 thing, change the width and centre it using auto that when you move from home to forum the layout stays fixed? it doesn't move even slightly?

                Comment


                • #9
                  Anyway I made it 800px just for now.

                  I reset everything to default then tried again still the same, shifts from left to right

                  Comment


                  • #10
                    Originally posted by aaronater View Post
                    Are you saying that if you make a fresh install of vb4 suite, (just to be thorough without cms default data) then only do 1 thing, change the width and centre it using auto that when you move from home to forum the layout stays fixed? it doesn't move even slightly?
                    No, I'm not saying that. I have checked my 4.1.8 default test site and I do not see that shift at all. I even changed it to 800 px and see no shift going from Home to Forum to Blogs to What's New.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools <- awesome site for html/css help

                    Comment


                    • #11
                      Sorry Lynne you misunderstood me, I am not asking you are saying I'm lying or it doesn't happen

                      I literally mean when you install and change that setting, does the same problem not occur for you.

                      I'm sorry for the way I worded that it seemed a bit brash.

                      So to answer the question, YES! You are saying that when you center and fix the width that it doesn't move .

                      OK well, can we keep this open, I am going to continue working around it and I will upload to a webhost by the weekend.

                      If I see the problem again I will come back. Just to add this is a brand new laptop latest vbulletin and latest xampp all browsers updated.

                      Comment


                      • #12
                        Hey,

                        I found the problem but cannot work out the logic behind it, its so weird! When I installed it there were already some settings that had been changed?

                        I wonder is this my pc???? When I installed xampp it was in german but I selected english. Thing is it's brand new pc brand new vbulletin....

                        Anyway as I said we will see if it persists on the webserver.

                        I should have done as wayne said and did that search for any vars that have been edited.

                        I will upload probably on saturday so i will let you know
                        Last edited by aaronater; Wed 14th Dec '11, 5:58pm.

                        Comment


                        • #13
                          When you installed it, were you using an existing database or did you create a new one for the installation. Our of curiosity, which setting was causing the issue? (Did you have a different style set for the Blogs/CMS versus the Forums?)

                          (And I didn't take your post wrong - I knew what you were trying to say, so sorry if my reply came off wrong.)

                          Please don't PM or VM me for support - I only help out in the threads.
                          vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                          Want help modifying your vbulletin forum? Head on over to vbulletin.org
                          If I post CSS and you don't know where it goes, throw it into the additional.css template.

                          W3Schools <- awesome site for html/css help

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X