Announcement

Collapse
No announcement yet.

VBSeo Broke my vb 4.2.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • VBSeo Broke my vb 4.2.2

    Hello everyone.

    I upgraded from 4.1.3 to 4.2.2. Like an idiot I enabled VBSeo.

    Now when I try to access admincp I get this error.
    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo_pre.php on line 279

    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo_pre.php on line 86

    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo_pre.php on line 129

    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo_pre.php on line 130

    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo_pre.php on line 131

    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo_pre.php on line 132

    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo.php on line 17

    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo.php on line 18


    Warning: Non-static method vBSEO_Storage:ath() should not be called statically in ..../vbseo/includes/functions_vbseo.php on line 26

    Is there anything I can do or am I forced to import my database backup and redo everything?

    Worst case I see having to re upload 4.1.3 import my DB, then upgrade to 4.2.2 again.


    ANY help?

    Thanks.

  • #2
    We can't help with vBSEO itself as it's a third party product. However try the advice in this post: http://www.vbulletin.com/forum/forum...66#post4000466
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      vbseo is working fine for me.. it depends on what version your using too.

      Comment


      • #4
        Frankly, anyone who did not already have vBSEO running, would be ill-advised to enable it now. The company no longer exists. It's a dead product.
        MARK.B | vBULLETIN SUPPORT

        TalkNewsUK - My vBulletin 5.6.4 Demo
        AdminAmmo - My Cloud Demo

        Comment


        • #5
          thanks for the advice, I will try that.

          Fresh foot what version did you have?

          I realize VB staff can't help with vbseo. I am just looking for a way to undo my "enabling" of the product. So i can go back to my shiny new install of 4.2.2

          Can i upload my 4.1.3 database then rerun the upgrade.php?

          Comment


          • #6
            That won't fix anything. You should either look at uninstalling vBSEO, or migrating to a replacement product.

            You can try adding the skip errors line, and enabling plugin compatibility in the Settings > Options > Products & Plugins Settings group As of vBulletin 4.2.2 we’ve stopped suppressing notices and warnings. This is a change from all previous versions of the software.
            In some environments more notices/warnings show than in others. In order to address the issue you just need to add the following line to your config.php file
            define('SKIP_ALL_ERRORS', true);
            You can see additional information about this change here: http://www.vbulletin.com/forum/forum...-been-released

            Comment


            • #7
              Bailer, You're receiving those warnings because of incompatibilities with the VBSEO PHP and PHP v5.4. You can disable the display of the warnings by adding a line to your config.php (see Zachery's post above). But, like everyone else said, it is a dead, unsupported product. Get rid of it. Instead of starting over, why not just try going into the vB admincp Products and uninstall VBSEO. Then remove all of the vbseo files from the web directory, including the .htaccess. I believe there is a vbseo directory and probably files in admincp and includes. You should be able to use grep/find to get them all.

              I just removed mine as part of an upgrade. I found that the uninstall left all of the database mods intact. You can just dump the database schema (do a normal mysqldump like you would for a backup except add --no-data as a switch. Then you can grep the file for 'vbseo' and find all of the fields and tables and remove them. You probably don't have too, but I like to clean up the mess before moving on. Here is what I came up with:

              ALTER TABLE `blog`
              DROP `vbseo_likes`;

              ALTER TABLE `forum`
              DROP `vbseo_moderaterefbacks`,
              DROP `vbseo_moderatepingbacks`,
              DROP `vbseo_moderatetrackbacks`,
              DROP `vbseo_enable_likes`;

              ALTER TABLE `thread`
              DROP `vbseo_linkbacks_no`,
              DROP `vbseo_likes`;

              ALTER TABLE `user`
              DROP `vbseo_likes_in`,
              DROP `vbseo_likes_out`,
              DROP `vbseo_likes_unread`;

              DROP TABLE IF EXISTS `vbseo_blacklist`;
              DROP TABLE IF EXISTS `vbseo_likes`;
              DROP TABLE IF EXISTS `vbseo_linkback`;
              DROP TABLE IF EXISTS `vbseo_serviceupdate`;

              Comment


              • #8
                Thank you for your help mark and zachary, that at least got me back into my admin cp. Can not thank you fellas enough.

                Vicos! I am the same way mate. I will be removing all remnants of vbseo.


                Thanks again for

                Comment

                Related Topics

                Collapse

                • geovadim
                  Update errors
                  by geovadim
                  I am trying to update my forum vb3.7 to vb5 connect. I've copied the files from vb5 in a test forum and created a copy of the live database.

                  PHP Version 5.4.38

                  I went to upgrade...
                  Mon 2 Mar '15, 2:18am
                • Mevlüt Akpinar
                  Error :API Error
                  by Mevlüt Akpinar
                  Hello,
                  Etc. 5 I smoke. I do not have a shortage of time following entry but I also enter my login information (in debug mode) I get the following errors.



                  Error :API E...
                  Tue 22 Dec '15, 12:42pm
                • avitor
                  sitemap not shows
                  by avitor
                  why i get this when i try to view sitemap after build sitemap ?
                  this message shows just after completed sitemap build
                  Sitemap built successfully. You may view the XML here.
                  and when
                  ...
                  Wed 3 Feb '16, 3:57pm
                Working...
                X