Announcement

Collapse
No announcement yet.

links error whit rewrite

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • links error whit rewrite

    Hi
    I've enabled friendly url from vbulletin settings according the picture but google webmaster for the must link get a 404 error message

    In fact in vbseo options i enabled Include Show Post Page, and I think because it did not convert command (showpost.php) htaccess file is in.

    Sample link whit 404 error:

    https://www.farsisats.net/post/260116-darkhast-komak
    https://www.farsisats.net/post/258222-strang-4620


    my htaccess code:

    RewriteEngine on

    # This file is only needed if you have set the Forum Component URL in your admincp and you are
    # using the mod_rewrite option for friendly urls. If this is the case, copy this file
    # to your forum component stub directory.

    # If you are having problems or are using VirtualDocumentRoot, uncomment this line and set it to your forum component directory.
    # RewriteBase /forum-stub-directory/

    # If you are having problems with the rewrite from content/ to content.php, uncomment this line to turn MultiViews off.
    # Options -MultiViews


    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule
    ^.*$ - [NC,L]

    # Forum
    RewriteRule ^threads/.* showthread.php [QSA]
    RewriteRule ^forums/.* forumdisplay.php [QSA]
    RewriteRule ^members/.* member.php [QSA]



    RewriteEngine On
    RewriteBase
    /
    RewriteRule ^((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 [L]




    # 480 weeks
    <FilesMatch "\.(ico|pdf|flv|jpg|jpeg|png|gif|js|css|swf)$">
    Header set Cache-Control "max-age=290304000, public"
    </FilesMatch>

    # 2 DAYS
    <FilesMatch "\.(xml|txt)$">
    Header set Cache-Control "max-age=172800, public, must-revalidate"
    </FilesMatch>

    # 2 HOURS
    <FilesMatch "\.(html|htm)$">
    Header set Cache-Control "max-age=7200, must-revalidate"
    </FilesMatch>

    Attached Files
    We do not do buying and extended

  • #2
    The mod_rewrite options in the default vBulletin settings are not compatible with vBSEO and we can't provide support for vBSEO.

    You will need to uninstall vBSEO and use the .htaccess file provided with your version of vBulletin in the do_not_upload/rewrite/apache2 directory.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X