Announcement

Collapse
No announcement yet.

Error 1146 - Missing Table Please Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error 1146 - Missing Table Please Help

    Hello all,

    I'm trying to move thousands of users from one group to another, then suddenly I get this error.



    The config file has never been changed as I am the one who has access to the admin panel only.

    Thanks in advance!

  • #2
    You don't have a table prefix?

    Comment


    • #3
      I'm not quite expert in technical, however the table prefix is "vb_"

      Pasting from Config.php

      // ****** DATABASE NAME ******
      // This is the name of the database where your vBulletin will be located.
      // This must be created by your webhost.
      $config['Database']['dbname'] = 'bmwclub_vb4';

      // ****** TABLE PREFIX ******
      // Prefix that your vBulletin tables have in the database.
      $config['Database']['tableprefix'] = 'vb_';

      Comment


      • #4
        Then you would need to access vb_user not user. The table prefix will need to be prefixed on all table names for all queries.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • randomx
          randomx commented
          Editing a comment
          Can you please tell me what query I need to type?

      • #5
        And how can I do that ? The table is already there!



        I've tried repairing and optimizing but that didn't work.

        Comment


        • #6
          You have to change your query, to use vb_user instead of user

          Comment


          • #7
            Can you guide me please on how to do it? What should I type exactly?

            Comment


            • #8
              :bump:

              Comment


              • #9
                I'm sorry for bumping again, but I believe it's a simple and tiny query that needs to be inserted, and I have 180,000 users to filter

                Can somebody let me know what I should input?

                Thanks!

                Comment


                • #10
                  If you look at the image you originally posted, you can see that your query is:
                  Code:
                  update user
                  set usergroupid=4
                  where usergroup=3
                  and posts = 0
                  You need to find the word user and change it to vb_user.

                  If you don't know how to write, modify and run queries, you should not be trying to run queries against your database as you can easily make your vBulletin inoperable. In fact, I would say the query your attempting is dangerous and shouldn't be run at all. You should use the Move/Prune User tool instead.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • randomx
                    randomx commented
                    Editing a comment
                    I've got 120,000 accounts I need to prune. They're all left in the "Users awaiting email confirmation area" and there are real accounts in there that I don't want to delete.

                    I need to find the word "User" where exactly? in the query I typed?

                • #11
                  yeah, it is the second word in the query....
                  update user
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API - Full / Mobile
                  Vote for your favorite feature requests and the bugs you want to see fixed.

                  Comment


                  • randomx
                    randomx commented
                    Editing a comment
                    A new error has came up :\

                • #12
                  Thanks for your reply mate, now I am facing a different issue..




                  Comment


                  • #13
                    Silly me!! I needed to type usergroupid instead of usergroup ... MANY THANKS!!!!! problem solved!

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X