Announcement

Collapse
No announcement yet.

Different theme when logged out (after upgrading to 4.2.2)?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Different theme when logged out (after upgrading to 4.2.2)?

    As you can see here: http://www.kavoir.com/backyard/

    When the user is not logged in, it's the default vb theme but after the user logs in, it's my custom theme.

    This happens after upgrading to 4.2.2. Before upgrading, it's my custom theme universally, doesn't matter if the user logs in or not. Now after upgrading, the default theme keeps coming up when the user logs out.

    Can somebody help me why this happens? Thanks a lot!
    Every time I think of a potential way to delight people, I make a website. Otherwise I'm looking for the web hosting deals.

  • #2
    Have you added this line to your /includes/config.php file? Add it directly below the first line which is <?php

    PHP Code:
    define('SKIP_ALL_ERRORS'true); 
    If that doesn't help, disable hooks as explained below and see if that helps at all-

    To disable the plugin/hook system open your config.php which can be found in your forumroot/includes directory

    Just below
    Code:
    <?php
    enter
    Code:
    define('DISABLE_HOOKS', true);
    and save the file.

    If you would like to enable the plugin/hook system again, either remove the line again or simply comment that line out. To do so, add two forward slashes " / " so it will look like

    Code:
    // define('DISABLE_HOOKS', true);
    Next time you would like to disable the plugin/hook system again
    you simply have to remove the " // ".

    Comment


    • #3
      Thanks a lot Joe but this doesn't help. I added both define('SKIP_ALL_ERRORS', true); and define('DISABLE_HOOKS', true); in config.php immediately below <?php but it didn't fix the problem. Anything else I could give a try?
      Last edited by immediate; Wed 1 Jan '14, 6:58pm. Reason: add
      Every time I think of a potential way to delight people, I make a website. Otherwise I'm looking for the web hosting deals.

      Comment


      • #4
        Keep the SKIP_ALL_ERRORS line in the config.php that is good to have.

        In Admin CP -> Settings -> Options -> Style & Language Settings, is your custom style set as the default style?

        Comment


        • #5
          Thanks Joe it worked! It seems everything in Admin CP -> Settings -> Options has been reverted to default after this upgrade or something else?

          The page title of http://www.kavoir.com/backyard is "Forums" instead of "Kavoir Backyard".
          The Webmaster's Email is "[email protected]" instead of my own email. I had to manually change them to my own.
          The Admin CP -> Settings -> Options -> Style & Language Settings is also reverted to the "Default Style" instead of my own.

          What could be the cause of this? How can I prevent it from happening again? It would be annoying if it happens again. It's really weird.

          Thank you!
          Every time I think of a potential way to delight people, I make a website. Otherwise I'm looking for the web hosting deals.

          Comment


          • #6
            Very weird- the upgrade should not have reverted anything. I suggest you check the admin/control panel log under Logs and see if any of the changes were logged and if so how/when they were made.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X