Announcement

Collapse
No announcement yet.

vps timezone issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vps timezone issues

    I have googled all over and tried setting the timezone and time with WHM and SSH, and even php date_set_timezone( ); I have found out I cannot change the server localtime and do not know what it was set as default, but I have change the php.ini date.timezone with UTC,PST, America/Indianapolis and even tried setting some random timezones to get the time close enough to use. however I think by changing the time in WHM->servertime and timezone edit and also the php.ini date.timezone, I have messed something up and cannot get the time correct on my vbulletin board.

    I think my WHM time should have been setup to the localtime of the server and now I cannot put it back to default to fix this problem. My hoster did not tell me about vps localtime until after I changed all the time settings in WHM.

    my forum reads the time is
    "All times are GMT -9. The time now is 06:23 AM."

    but here the time is 6:22 pm, the forum posts and email times are the same way. How can i fix the time for vbulletin?

  • #2
    vBulletin pulls its time from the server operating system. If the server time isn't set correctly, vBulletin's won't be. You need to contact your host and have them adjust the time for you. Best is to sync it with a public time server on a regular basis.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Yes well they told me that they will not change this for me as it affects all others on the server. So I am stuck with the incorrect time?

      Comment


      • #4
        There is a timezone setting at easyapache update if you look at the exhaustive list option.

        Comment


        • #5
          I have not tried the timezone in easy apache but I have set this via the php.ini, are these 2 different settings?

          Comment


          • #6
            I have not tried it either, I have just noticed that it exists. Php.ini usually works for me.

            Comment


            • #7
              Ask them what timezone the server is set to and adjust your other settings accordingly. Probably set to UTF which means you should set PHP to UTC. vBulletin should be able to adjust based on your user settings.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API - Full / Mobile
              Vote for your favorite feature requests and the bugs you want to see fixed.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X