Announcement

Collapse
No announcement yet.

Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors

    I know there is a topic on this but I can't find it. When ever I post an article I get the following errors. It's been around awhile now so I am sure someone has a fix.

    Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261

    Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337

    Thank you in Advance
    Stress: The overwhelming desire to choke the s*@t out of someone.

  • #2
    Presuming you have updated to 4.2.2 after Nov 1st you need to:

    Add the following line to your config.php under the <?php line:
    PHP Code:
      define('SKIP_ALL_ERRORS'true); 

    Comment


    • #3
      Presuming you have updated to 4.2.2 after Nov 1st you need to:

      Add the following line to your config.php under the <?php line:
      PHP Code:
       define('SKIP_ALL_ERRORS'true); 

      I guess it's not my day. I added what you posted and it didn't work. I took out the STATEMENT and now I get this when I try to open the site:


      Warning: Unterminated comment starting line 2 in /home/wildflec/public_html/includes/config.php on line 2
      Configuration: includes/config.php exists, but is not in the 3.6+ format. Please convert your config file via the new config.php.new.
      I goofed some place.

      Don
      Stress: The overwhelming desire to choke the s*@t out of someone.

      Comment


      • #4
        Can you post the first few lines of your config.php so we can see if there is a mistake.

        Comment


        • #5
          Originally posted by donald1234 View Post
          Can you post the first few lines of your config.php so we can see if there is a mistake.
          Let me ask you if the config.php is the one in the includes directory correct? if it is this is what it is. I have looked at this a thousand times and I can only say "I am getting to old for this" and I know this file is not right. But anyway here it is. Don't laugh


          <?php
          /*======================================================================*\
          || #################################################################### ||
          || # vBulletin 4.2.0 Patch Level 3
          || # ---------------------------------------------------------------- # ||
          || # All PHP code in this file is
          I am running v4.2.2. Is there a way too recreate the config file or should I take "config.php.new" and fill in the blanks?

          Thanks
          Don
          Last edited by djmac; Wed 18th Dec '13, 3:33pm.
          Stress: The overwhelming desire to choke the s*@t out of someone.

          Comment


          • #6
            Is your forum working after you removed the above code. It should have looked like this.

            PHP Code:
            <?php
            define
            ('SKIP_ALL_ERRORS'true);
            /*======================================================================*\

            Comment


            • #7
              When I did add the code the system failed. So I took it out and now I can get into the site. I get this when I do try.

              Warning: Unterminated comment starting line 2 in /home/wildflec/public_html/includes/config.php on line 2
              Configuration: includes/config.php exists, but is not in the 3.6+ format. Please convert your config file via the new config.php.new.
              The last part of the error says " Please convert your config file via the new config.php.new." how do I do that? or do I just fill in the blanks.

              I left you a private message did you read it?

              Don
              Stress: The overwhelming desire to choke the s*@t out of someone.

              Comment


              • #8
                I see now what I have to do. I need to fill out config.php.new and rename it to config.php That's the fix. I'll let you know what happens. ( I read the FAQ's. LOL) Thanks again Don Have a great day and stay safe.
                Stress: The overwhelming desire to choke the s*@t out of someone.

                Comment


                • #9
                  It must be the 4.2.0 config.php that is different as mine is working fine with a 4.2.1 config.php

                  Comment


                  • #10
                    It was probably the text editor used adding hidden characters to the file. Windows Notepad is notorious for this. A free alternative like Notepad++ should be used in Windows,

                    Comment


                    • #11
                      Originally posted by Joe D. View Post
                      It was probably the text editor used adding hidden characters to the file. Windows Notepad is notorious for this. A free alternative like Notepad++ should be used in Windows,
                      How do I tell if the cpanel editor is adding hidden characters? I don't use cpanel edit as a rule. I did however use it to insert and remove the define('SKIP_ALL_ERRORS', true);" I use EditPad Pro. Been using it for years. What is odd is when I access cpanel and go to files and select config.php.new and select view I see the whole file when I select edit I only see what is posted in post #5 above in this forum. What I have to do cut and paste the config.php.new to editpad and create a new config.php.correct? If there is a better way I surely can use it.

                      Thanks Much
                      Don
                      Stress: The overwhelming desire to choke the s*@t out of someone.

                      Comment


                      • #12
                        I'm not sure how cpanel editor works.

                        You should - on your local machine with EditPad Pro- open config.php.new, make changes so it matches your old config.php values, then save the file as config.php and upload it to your server.

                        Comment


                        • #13
                          I did that Joe. I rebuilt my Config.php and added the following to the top of the config file:

                          <?php
                          define('SKIP_ALL_ERRORS', true);
                          /*======================================================================*\
                          || #################################################################### ||
                          || # vBulletin 4.2.2
                          The site is back up and running BUT! I still get the errors after I write an article and save to publish:

                          Warning: Declaration of vBForum_Item_SocialGroupMessage::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupmessage.php on line 261

                          Warning: Declaration of vBForum_Item_SocialGroupDiscussion::getLoadQuery() should be compatible with that of vB_Model::getLoadQuery() in ..../packages/vbforum/item/socialgroupdiscussion.php on line 337
                          Stress: The overwhelming desire to choke the s*@t out of someone.

                          Comment


                          • #14
                            I see you have ticket support, please open a ticket- include FTP details and Admin CP login details in the sensitive data potion of the ticket. Mention you already have the skip all errors line in config.php.

                            A support ticket can be opened in the Member's Area.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X