Announcement

Collapse
No announcement yet.

Moving Servers, can no longer log in to Admincp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Joe D.
    replied
    Everything is pointing to some sort of server configuration issue, I am sorry I can't be more helpful. You should undo the file edit I asked you to make, I didn't intend for it to be permanent.


    Leave a comment:


  • Webbstre
    replied
    After further analysis, here are further places where the security token error appears:
    • When trying to post from Quick Reply
    • When trying to make a new thread
    • When trying to preview any kind of post/message
    • When trying to send a PM
    • When trying to edit my signature.
    In addition to the inability to complete a login.

    Leave a comment:


  • Webbstre
    replied
    Originally posted by Zachery View Post
    Those tables are normally like that, and it has nothing to do with the other issues.


    Does your webhost have mod_security, suhosin, or another security application on the server?
    Those two specifically, no. I believe I tried compiling PHP with them before and I ran into other problems and a search recommended not implementing them into php with vbulletin. If you have recommendations I can recompile it any way you suggest, as the new server I'm trying to move to isn't live yet.

    Originally posted by Joe D. View Post
    The code is a "sanity check" it is really checking for a situation that should never be possible- you should never have a content_length without a POST value because it is only set by POST requests.

    It must be some way the server is setup causing this issue.

    If you find the line
    Code:
    die('The file(s) uploaded were too large to process.');
    In your init.php file and "comment it out" (AKA- change it to)

    Code:
    //die('The file(s) uploaded were too large to process.');
    What happens?
    I get to a vbulletin error page that says the following:
    Your submission could not be processed because a security token was missing.

    If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.
    Last edited by Webbstre; Mon 16th Dec '13, 1:42pm.

    Leave a comment:


  • Joe D.
    replied
    The code is a "sanity check" it is really checking for a situation that should never be possible- you should never have a content_length without a POST value because it is only set by POST requests.

    It must be some way the server is setup causing this issue.

    If you find the line
    Code:
    die('The file(s) uploaded were too large to process.');
    In your init.php file and "comment it out" (AKA- change it to)

    Code:
    //die('The file(s) uploaded were too large to process.');
    What happens?

    Leave a comment:


  • Zachery
    replied
    Those tables are normally like that, and it has nothing to do with the other issues.


    Does your webhost have mod_security, suhosin, or another security application on the server?

    Leave a comment:


  • Webbstre
    replied
    Could this be related? I was checking in myphpadmin and found the check and repair database buttons two tables do not show up as OK:

    [databasename.cpsession] note: The storage engine for the table doesn't support check
    [databasename.session] note: The storage engine for the table doesn't support check
    [databasename.cpsession] note: The storage engine for the table doesn't support repair
    [databasename.session] note: The storage engine for the table doesn't support repair
    I should note that the error in question appear during the login process (regular or admincp) AFTER the login is successful and the redirect page shows up.

    Leave a comment:


  • Webbstre
    replied
    Thank you for looking into it
    Right now I'm trying to basically start the whole process over, from recompiling php to turning off all datastore options and clearing the caches before backing up and moving over. Maybe I'll get lucky and the error will go away once the current attempt is finished. Either way I appreciate suggestions!

    Edit: Nope, same error still
    Last edited by Webbstre; Sat 14th Dec '13, 5:19pm.

    Leave a comment:


  • Joe D.
    replied
    Webbstre, I learn something new every day- I did a full search of the vBulletin source code and did indeed find "The file(s) uploaded were too large to process." is an obscure error message in init.php.

    The code triggering it is this-

    Code:
        if (empty($_POST) AND isset($_SERVER['CONTENT_LENGTH']) AND $_SERVER['CONTENT_LENGTH'] > 0)
        {
            die('The file(s) uploaded were too large to process.');
        }
    Unfortunately I don't have an immediate answer why you are having an issue, it does appear to be some reason why $_POST is empty on your server, but I will try to get you a better answer.

    Leave a comment:


  • Webbstre
    replied
    It's not a server error, it's a vbulletin-specific error. I try to log in, and it says "The file(s) uploaded were too large to process." despite not uploading anything. There are several other people who have posted the same problem on these forums, but no one has posted a solution. Plus if you google the phrase, ONLY vBulletin sites come up as a result.

    Leave a comment:


  • Lynne
    replied
    Since it is a server error, have you asked your host about it?

    Leave a comment:


  • Webbstre
    replied
    Ok, I've gone in and reset all the caches, checked and repaired all of my tables... and the problem remains. :/ XCache and plugins are still all turned off. Any other suggestions?

    Leave a comment:


  • Joe D.
    replied
    To refresh the datastore you need to upload tools.php from the do_not_upload folder of the original vBulletin install package. Upload it to your admincp directory. Note- for tools.php to work you must also upload your /install/ directory but delete install.php and upgrade.php while you use tools.php.

    When done with tools remove the /install/ directory completely.

    In tools use the link to refresh the options cache - that will refresh the datastore.

    To get to tools.php manually enter the url in your browser.

    Leave a comment:


  • Webbstre
    replied
    Here's an update, in addition to the edits to the original post: I thought I fixed the problem and had moved on to a new error, but in reality the new error was just preventing me from reaching the "The file(s) uploaded were too large to process." message. I have removed most of the phpinfo from above. Additionally, I currently have all caching turned off and all hooks/plugins disabled. I cannot log in normally or to admincp without the above message. I cannot make any posts, but I can use the search functionality.

    For the datastore thing above, is there a way to refresh/clear it without having access to admincp, such as through phpmyadmin?

    Leave a comment:


  • Joe D.
    replied
    You say you can't log into the Admin CP- do ANY pages work? The error looks like it would be some sort of configuration error and I'd guess nothing is really working in that case?

    Leave a comment:


  • rhens
    replied
    you may not be able to...but now every hacker on the planet can....(smh)

    Leave a comment:

Related Topics

Collapse

Working...
X