Announcement

Collapse
No announcement yet.

Emails Not Sending

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Emails Not Sending

    Hi there

    I've recently moved my forum from a shared Linux server to a dedicated Windows server running Plesk. The emails were previously working fine, but now are not. I have tried to diagnose and fix this myself but unfortunately have had no luck so have resorted to asking for help.

    Here's what I have tried alread:

    1. Sending with -f parameter
    2. Changing from php mail() to SMTP mail, not only with a SMTP server on the same host, but also changing it BACK to the old host, which I know works (because the forum was installed there previously).
    3. The domain is the same so nothing should make any difference there
    4. The MX records are set correctly for the domain
    5. Sending an email through the maintenance panel strangely does work, but it never includes the forum name, just the "from" email address. On some webmail clients this has shown up as "unknown sender"
    6. Sending through the 'contact us' page does not work
    7. Turning on mail queuing does not change anything
    8. I know the mail server does work because I have email accounts set up through outlook that work perfectly fine. I have also set up a test PHP file on the server to use the mail() function and that also works fine.
    9. I have been through the troubleshooting article on this site and that offered no solutions.

    I have tried and tried and tried but nothing seems to work. Based on what I have tried, I'm led to believe this might be a vB bug. However I'm certainly not an expert

    It's very important that I get this working as new users are unable to complete their registrations due to the lack of email confirmations.

    Kind Regards
    Callum

  • #2
    I'd just like to add to this, I have several Wordpress installations running off the same server. All of which are working fine with regard to emails.

    Comment


    • #3
      Did you check your email log on the server?
      Gentoo Geek

      Comment


      • #4
        Problem solved, it was infact due to my datastore directory not being writable, so the old SMTP settings were still being used.

        *facepalm*

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X