Announcement

Collapse
No announcement yet.

vB 4.1.8 "enhanced" editor broken

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zachery
    replied
    The problem is, not everyone has those third party addons installed, and we always recomend disabling third party products first.

    Again, which is why everyone should open their own thread.

    Your problem, while similiar, may not be someone elses.

    Leave a comment:


  • mmackinnon
    replied
    Doug

    Thanks, if not for you posting in this thread may would not have a fix. Seems to me that the vb support people should learn from this.

    Leave a comment:


  • Doug Brott
    replied
    After submitting a JIRA (http://tracker.vbulletin.com/browse/VBIV-13671), I received a helpful pointer for where I should look. I disabled a plugin that was working just fine in 4.1.7.PL2 but was breaking things in 4.1.8

    BBR - Resize Images with lytebox v3.22
    http://www.vbulletin.org/forum/showthread.php?t=230411

    Apparently the plugin author is no longer maintaining it, so I guess it's not entirely surprising.

    Perhaps I should have known to do this, but since my site is more of a hobby than a business and I pretty much let it run as-is, it wasn't my first thought to look in that area (it had worked in the previous version after all).

    So for other folks having this issue, check your plugins/products .. There seems to have been enough changes at this point that old ones may not work properly. I disabled them one by one until I found the one that was causing the problem. In my case, I left it disabled since it is no longer supported. However, your mileage may vary.

    Leave a comment:


  • Doug Brott
    replied
    Really?! I'm having the exact same problem as the original poster. I've solved it using the fix that he provided (Which isn't really a fix). Do you Private Message the answer to the questions? A publicly posted solution to the original problem would have been extremely helpful to me.

    I can only assume a new thread will get a similar non-response so what's the point? I'll live with what I have. <shrug>

    Leave a comment:


  • Zachery
    replied
    Doug, as requested earlier, please start your own thread or ticket for help with the issue and provide full details. There is no "fix" because it really depends on what is wrong in the first place.

    Leave a comment:


  • Doug Brott
    replied
    So what's the fix? I'm having the same problem. All of my users are having to change to the WYSIWYG editor to make a quick post.

    Leave a comment:


  • Zachery
    replied
    Originally posted by mmackinnon View Post
    Zach

    If you represent vb support then you need a lesson in customer service. I am echoing this individuals statements showing that it is an issue for more than one person. Learn some manners.
    I woud ask that you also respect the staff and the general rules of conduct for our forum. Often customers have issues that look similar but are not. It is also very hard for us to troubleshoot multiple peoples issues in the same thread.

    Leave a comment:


  • mmackinnon
    replied
    Originally posted by Zachery View Post
    Erm, you do understand the "enahcned" editor is the wysiwyg right? And it is working fine.


    Dont hijack others threads, start your own
    Zach

    If you represent vb support then you need a lesson in customer service. I am echoing this individuals statements showing that it is an issue for more than one person. Learn some manners.

    Leave a comment:


  • MEsh3L85
    replied
    it's working fine with me too

    Leave a comment:


  • Zachery
    replied
    Originally posted by cshepherd View Post
    Recently upgraded from 4.1.7 to 4.1.8, and noticed the 'Article Comments' editor was broken (showed a solid grey box) in all browsers except Firefox. Javascript error is: "Cannot call method 'setState' of undefined" in ckeditor.js, best guess is that I'm missing a DOM object?

    Was able to workaround by setting Registration Prefs to default new users to WYSIWYG Editor, and did SQL "UPDATE users SET showvbcode=2;". Forcing everyone to WYSIWYG instead of 'enhanced' is a workaround that solved the issue for tonight, and I'm guessing the vast majority (or all) of forum users will not notice or care about this change. But it's still a workaround and not a fix.

    What's interesting is that Maintenance -> Suspect Files doesn't show anything interesting, and even if I go to Default style and revert all templates and stylevars, the problem persists if I switch to Enhanced instead of WYSIWYG. Yet I am unable to duplicate the issue here at vbulletin.com forums, which is also 4.1.8, so I must assume it's something on my end. Also both default mobile styles are set to 'None'.

    You can witness the issue for yourself at http://gracegothealthy.com/ (registration is required to show article comments editor, or I can create an account for you if you prefer).

    If someone could point me in a new direction, I'd be most grateful. And thank you!

    Erm, you do understand the "enahcned" editor is the wysiwyg right? And it is working fine.
    Originally posted by mmackinnon View Post
    many of my users are seeing the same issue with quick reply in any of the forums. they have to click "go advanced" just to make a post.

    Dont hijack others threads, start your own

    Leave a comment:


  • mmackinnon
    replied
    many of my users are seeing the same issue with quick reply in any of the forums. they have to click "go advanced" just to make a post.

    Leave a comment:


  • cshepherd
    replied
    You betcha.

    http://gracegothealthy.com/
    Username: vbtest
    Password: vbtest123

    Leave a comment:


  • Zachery
    replied
    Can you make a test account for us?

    Leave a comment:


  • cshepherd
    started a topic [Forum] vB 4.1.8 "enhanced" editor broken

    vB 4.1.8 "enhanced" editor broken

    Recently upgraded from 4.1.7 to 4.1.8, and noticed the 'Article Comments' editor was broken (showed a solid grey box) in all browsers except Firefox. Javascript error is: "Cannot call method 'setState' of undefined" in ckeditor.js, best guess is that I'm missing a DOM object?

    Was able to workaround by setting Registration Prefs to default new users to WYSIWYG Editor, and did SQL "UPDATE users SET showvbcode=2;". Forcing everyone to WYSIWYG instead of 'enhanced' is a workaround that solved the issue for tonight, and I'm guessing the vast majority (or all) of forum users will not notice or care about this change. But it's still a workaround and not a fix.

    What's interesting is that Maintenance -> Suspect Files doesn't show anything interesting, and even if I go to Default style and revert all templates and stylevars, the problem persists if I switch to Enhanced instead of WYSIWYG. Yet I am unable to duplicate the issue here at vbulletin.com forums, which is also 4.1.8, so I must assume it's something on my end. Also both default mobile styles are set to 'None'.

    You can witness the issue for yourself at http://gracegothealthy.com/ (registration is required to show article comments editor, or I can create an account for you if you prefer).

    If someone could point me in a new direction, I'd be most grateful. And thank you!

Related Topics

Collapse

Working...
X