Announcement

Collapse
No announcement yet.

Mobile users getting spam

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Mobile users getting spam

    I just upgraded from 4.1.3 to 4.1.8

    I am now getting re-directed to spam sites whenever I try to access my VB from my cell phone.

    Other users on the forum are complaining of the same problem. Any ideas? I checked all of my templates for iframe tags and didn't find any other than ones that are supposed to be there.

    Ran suspect file versions and got rid of all files not being used.

  • #2
    I am also using VBadvanced. Dont know if that has anything to do with it.

    Comment


    • #3
      Reimport the Mobile Style .xml files into a new Style and set this as your mobile defaults.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #4
        That doesn't even make sense.

        Comment


        • #5
          Thank you for the response. I am using vb4 Default Style which was a merged style I created way back when 4.0 first came out. I couldn't find the original .xml files. I'll try uploading a new style and see if that works?

          The site I'm having a problem with is www.fishingnetwork.net it works fine via PC but when accessed with a mobile device it goes to some russian spam site.

          I'll report back when I get a new style going...

          Comment


          • #6
            OK, I uploaded a new style and then set the mobile defaults to that style. It didn't work. I even cleared my cell phone cache to make sure I was getting a fresh download.

            I'm still lost and would appreciate some help.

            Comment


            • #7
              Do you have any addons installed? There shouldn't be any redirects off site in the default software.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment


              • #8
                The only add-on I have is vbAdvanced CMPS. I did notice a Skimlinks plugin that I deactivated, I don't ever remember installing that.

                Here's what my web host came up with when I reported the problem to them:

                Greetings

                Looks like iframes have been injected into some of your images which will only effect the web browsers used by smart phones.

                I located these in your logs after visiting the site using a pair of online smart phone emulators.

                -bash-3.00# grep 174.129. /usr/local/apache/domlogs/fishingnetwork.net
                174.129.228.67 - - [17/Nov/2011:06:56:45 -0600] "GET /forum4/showthread.php?48871-The-Manzanar-Fishing-Club-documenatry-Update HTTP/1.0" 302 398 "-" "ia_archiver (+http://www.alexa.com/site/help/webmasters; [email protected])"
                174.129.228.67 - - [17/Nov/2011:06:56:57 -0600] "GET /forum4/showthread.php?50421-Indoor-fishing-ponds HTTP/1.0" 302 398 "-" "ia_archiver (+http://www.alexa.com/site/help/webmasters; [email protected])"
                174.129.80.76 - - [17/Nov/2011:10:30:30 -0600] "GET /forum4/image.php?u=31884&dateline=1264664542 HTTP/1.1" 200 7101 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (FlipboardProxy/0.0.5; +http://flipboard.com/browserproxy)"
                174.129.80.76 - - [17/Nov/2011:10:30:30 -0600] "GET /forum4/image.php?u=36514&dateline=1297794331 HTTP/1.1" 200 3549 "-" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (FlipboardProxy/0.0.5; +http://flipboard.com/browserproxy)"

                Thanks,

                Nate.S
                Level 2 Tech Support


                So now I am looking for the images that are used by cell phones. Any help would be appreciated. CPStyles?

                Comment


                • #9
                  Originally posted by n2fshn View Post
                  So now I am looking for the images that are used by cell phones. Any help would be appreciated. CPStyles?
                  You stated that you don't have the mobile style installed and are only using the Default master style. There are no mobile phone specific images in the default master style.
                  Translations provided by Google.

                  Wayne Luke
                  The Rabid Badger - a vBulletin Cloud demonstration site.
                  vBulletin 5 API

                  Comment


                  • #10
                    OK so I've checked my images/mobile directory and all of the images are the same as the 4.1.8 that I've just installed. I deleted them all and uploaded new ones just to be sure.

                    I checked my style vars and made sure the imgdir_mobile path is set to images/mobile.

                    I am still getting the same re-direct. I'm not sure where to look next.

                    Comment


                    • #11
                      Originally posted by Wayne Luke View Post
                      You stated that you don't have the mobile style installed and are only using the Default master style. There are no mobile phone specific images in the default master style.
                      I uploaded a new style that I got from vbulletin.org and I named it style3. Then I went into Settings / Options / Style & Language settings and changed both old and modern Mobile Browsers to "style3"

                      Comment


                      • #12
                        Originally posted by Wayne Luke View Post
                        You stated that you don't have the mobile style installed and are only using the Default master style. There are no mobile phone specific images in the default master style.
                        There is an images/mobile directory in 4.1.8. those are the images I am talking about.

                        Comment


                        • #13
                          Originally posted by n2fshn View Post
                          There is an images/mobile directory in 4.1.8. those are the images I am talking about.
                          Yes, but they would only get called if you install our Mobile Style. Otherwise they just sit on your system and take up space.

                          Your style3 is what is served to mobile devices if you have Modern Mobile and Old Mobile defaults set to it. You would have to check its files and templates to make sure there aren't any compromises.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API

                          Comment


                          • #14
                            Originally posted by Wayne Luke View Post
                            Yes, but they would only get called if you install our Mobile Style. Otherwise they just sit on your system and take up space.

                            Your style3 is what is served to mobile devices if you have Modern Mobile and Old Mobile defaults set to it. You would have to check its files and templates to make sure there aren't any compromises.
                            I only installed the style3 just today in response to your first post.

                            The re-direct seems to take place no matter which style is being used.

                            Comment


                            • #15
                              You'll need to open a ticket then. We'll need access to look at things.

                              https://www.vbulletin.com/go/techsupport
                              Translations provided by Google.

                              Wayne Luke
                              The Rabid Badger - a vBulletin Cloud demonstration site.
                              vBulletin 5 API

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X