Announcement

Collapse
No announcement yet.

Youtube Embedding

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Youtube Embedding

    I'm trying to walk through how I set it up originally but cannot figure out. I have a BBcode called [video]. How I normally do it is do http://www.youtube.com/videourl. I looked and I don't have any BBcode whatsoever for this tag. So how in the world did I accomplish this? I don't see any addons installed for it either under Products.

    I'm on 4.2.2.

    Edit: Here is the BBcode I used: [video=youtube;Z4sKg18lTqw]http://www.youtube.com/watch?v=Z4sKg18lTqw[video] (I didn't put the proper slash on the final tag just so you can see the code), which is what I want, but it shows a URL instead of the video. The movie portion, Z4sKg18lTqw, gets automatically parsed into the tag. I like hyperlinking the whole URL to the tag.

    http://i.imgur.com/AV4YcOn.png
    Last edited by vivalanation; Sun 10th Nov '13, 2:11am.

  • #2
    http ://youtube.com/Z4sKg18lTqw
    Originally posted by vivalanation View Post
    I'm trying to walk through how I set it up originally but cannot figure out. I have a BBcode called [video]. How I normally do it is do http://www.youtube.com/videourl. I looked and I don't have any BBcode whatsoever for this tag. So how in the world did I accomplish this? I don't see any addons installed for it either under Products.

    I'm on 4.2.2.

    Edit: Here is the BBcode I used: [video=youtube;Z4sKg18lTqw]http://www.youtube.com/watch?v=Z4sKg18lTqw[video] (I didn't put the proper slash on the final tag just so you can see the code), which is what I want, but it shows a URL instead of the video. The movie portion, Z4sKg18lTqw, gets automatically parsed into the tag. I like hyperlinking the whole URL to the tag.

    http://i.imgur.com/AV4YcOn.png
    Remove the space after http and try:

    http ://youtu.be/Z4sKg18lTqw



    vB5 is unequivocally the best forum software, but not yet...

    Comment


    • #3
      Huh? There is no whitespace anywhere in what I posted.

      Comment


      • #4
        Originally posted by vivalanation View Post
        Huh? There is no whitespace anywhere in what I posted.
        There isn't in your post, there is one in my post, remove that and try to embed that.




        vB5 is unequivocally the best forum software, but not yet...

        Comment


        • #5
          I don't understand what you want me to do...

          I figured out what you wanted. I copied it and pasted it in to the tags and I get this:

          http://i.imgur.com/GtZjyEI.png
          Last edited by vivalanation; Sun 10th Nov '13, 3:01am.

          Comment


          • #6

            Originally posted by vivalanation View Post
            I don't understand what you want me to do...

            I figured out what you wanted. I copied it and pasted it in to the tags and I get this:

            http://i.imgur.com/GtZjyEI.png
            This is the link without my whitespace after http:
            Code:
            http://youtu.be/Z4sKg18lTqw
            Click on the Insert Video icon in the editor and paste it in, it will become:
            Code:
            [video = youtube_share;Z4sKg18lTqw]http://youtu.be/Z4sKg18lTqw[/video]
            Does it work?

            Edit:
            Code does not work here, remove the whitespaces:
            [VID EO]h ttp://youtu.be/Z4sKg18lTqw[/VI DEO]
            Last edited by beishe8; Sun 10th Nov '13, 3:26am.


            vB5 is unequivocally the best forum software, but not yet...

            Comment


            • #7
              It does not work, still just creates a hyperlink to the Youtube video.

              Comment


              • #8
                Originally posted by vivalanation View Post
                It does not work, still just creates a hyperlink to the Youtube video.
                This editor is terrible.
                Just copy this:
                [VID EO]h ttp://youtu.be/Z4sKg18lTqw[/VI DEO]

                and paste it in in your forum without the whitespaces in it.


                vB5 is unequivocally the best forum software, but not yet...

                Comment


                • #9
                  Same thing, just converts it to a hyperlink.

                  Comment


                  • #10
                    Originally posted by vivalanation View Post
                    Same thing, just converts it to a hyperlink.
                    It not supposed to put <a ....</a> there.
                    It's mixing BBCode with HTML?


                    vB5 is unequivocally the best forum software, but not yet...

                    Comment


                    • #11
                      Agreed, it should not be doing that. And the result seems to differ depending on which URL I link.

                      Right now it's just parsing the hyperlink, so I think it has something to do with the [video] tags, but before I did not have any specific BBcodes for it.
                      Last edited by vivalanation; Sun 10th Nov '13, 4:18am.

                      Comment


                      • #12
                        Axiomatic Colleague of Mine:

                        I faced the same problem. Posting YouTube videos never worked in my forum (vBulletin 4.2.0). The solution I found is to embed code with the editor in source mode. Every YouTube video has a function labeled embed code. You copy the code and paste it to your post:

                        http://forums.saliu.com/forum-admini...nistrator.html

                        On the YouTube page of the video, click Share, the Embed, then copy the code:

                        <iframe width="420" height="315" src="//www.youtube.com/embed/pg10ONophXY" frameborder="0" allowfullscreen=""></iframe>

                        Best of luck, axio!

                        Ion Saliu,
                        Videographer At-Large
                        Last edited by Ion Saliu; Sun 10th Nov '13, 8:44am.

                        Comment


                        • #13
                          Hello,

                          Yes but I shouldn't have to.

                          Comment


                          • #14
                            You see?

                            Easy as that.......


                            Comment


                            • #15
                              Huh?

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X