Announcement

Collapse
No announcement yet.

Debugging the forum - FB warning

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Debugging the forum - FB warning

    While debugging my forum today, I've found a warning in the logs:

    Code:
    Warning: session_start() [[URL="http://www.oldrepublic.net/threads/function.session-start"]function.session-start[/URL]]: Cannot send session cache limiter - headers already sent (output started at /home/forum/public_html/includes/class_database_explain.php:220) in /home/forum/public_html/includes/facebook/facebook.php on line 37
    Is this something to worry about? How can I fix this?
    SWTOR Forums | Software Forums

  • #2
    nobody knows?
    SWTOR Forums | Software Forums

    Comment


    • #3
      There shouldn't be any output from that file. As far as I am aware, nothing in the /includes/ directory should have direct output to the browser.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #4
        oh...so how can I debug the problem then? I discovered it enabling debug mode in config.php but I don't know the cause

        update: I've overwrited the 2 files from includes class_database_explain.php and facebook.php from the vb 4.1.7 installation kit, hoping that was some kind of character outputed and couldn't see it in the editor. But this didn't resolved anything, so I'm back to square 1. If I disable the Facebook platform on the forum, the warning evidently dissapears
        Last edited by vexxy; Mon 7 Nov '11, 11:13pm.
        SWTOR Forums | Software Forums

        Comment


        • #5
          ok..another update..it seems this is the cause of my forum getting slow for a while. I've posted the thread on that matter here: https://www.vbulletin.com/forum/show...w-afer-a-while

          so basicly, it gets slow but if i disable facebook from admincp, the site is getting fast again. So, I really need to get rid of that warning, because it clogs the browser somehow
          SWTOR Forums | Software Forums

          Comment


          • #6
            Check the files for hidden characters before the <?php and after any existing ?> lines. Not all files will have the latter. Also make sure there are no echo statements in any files. By default there shouldn't be either but if you edit the files in a text editor, they can be added.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API

            Comment


            • #7
              actually I have replaced both files with the original version from the vb installation suite (just downloaded today). but I'll take a look again..just to confirm, you're referring only to those 2 files right?
              SWTOR Forums | Software Forums

              Comment


              • #8
                Make sure the facebook.php file is Unicode (UTF-8) encoding and not Unicode (UTF-8 with BOM) encoding.

                Please don't PM or VM me for support - I only help out in the threads.
                vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                Want help modifying your vbulletin forum? Head on over to vbulletin.org
                If I post CSS and you don't know where it goes, throw it into the additional.css template.

                W3Schools &lt;- awesome site for html/css help

                Comment


                • #9
                  double checked, it's UTF-8
                  SWTOR Forums | Software Forums

                  Comment


                  • #10
                    Do you have any custom pages? If I recall, the only time I have seen that error was on a custom page I wrote and I had saved the dustom page using the wrong encoding.

                    Please don't PM or VM me for support - I only help out in the threads.
                    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                    Want help modifying your vbulletin forum? Head on over to vbulletin.org
                    If I post CSS and you don't know where it goes, throw it into the additional.css template.

                    W3Schools &lt;- awesome site for html/css help

                    Comment


                    • #11
                      yep I have custom pages, but this warning is on every page..CMS home, forum threads...etc
                      SWTOR Forums | Software Forums

                      Comment


                      • #12
                        What happens if you run Maintenance > Diagnostics > Suspect File Version? Do any default vbulletin files get listed?

                        Please don't PM or VM me for support - I only help out in the threads.
                        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                        Want help modifying your vbulletin forum? Head on over to vbulletin.org
                        If I post CSS and you don't know where it goes, throw it into the additional.css template.

                        W3Schools &lt;- awesome site for html/css help

                        Comment


                        • #13
                          ncode_imageresizer_v1.5.js File not recognized as part of vBulletin
                          vbulletin-threadbit.js File not recognized as part of vBulletin
                          DD_belatedPNG_0.0.8a.js File does not contain expected contents
                          base_facebook.php File does not contain expected contents
                          facebook.php File does not contain expected contents
                          comments.php File does not contain expected contents (/packages/vbcms)

                          Also, base_facebook.php and facebook.php I have uploaded fresh after downloading the latest build, which is 4.1.7 patch lvl 2 but I currently have 4.1.7 maybe that's the cause?
                          SWTOR Forums | Software Forums

                          Comment


                          • #14
                            If you downloaded the latest package, then you should upload all the files from that package to the site. Otherwise, replace these with the files from the package that you originally uploaded so they not longer get listed in Suspect File Version:

                            base_facebook.php File does not contain expected contents
                            facebook.php File does not contain expected contents
                            comments.php File does not contain expected contents (/packages/vbcms)

                            Please don't PM or VM me for support - I only help out in the threads.
                            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
                            Want help modifying your vbulletin forum? Head on over to vbulletin.org
                            If I post CSS and you don't know where it goes, throw it into the additional.css template.

                            W3Schools &lt;- awesome site for html/css help

                            Comment


                            • #15
                              ok, I'll do that...however, comments.php was edited by me, I've added that fix where the custom thumbnails were not displayed within comments (gonna be fixed in 4.1.8).

                              Will uploaded those 2 and report back in several minutes.
                              SWTOR Forums | Software Forums

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X