Announcement

Collapse
No announcement yet.

Another Upgrade issue but with the Class_bitfield_builder.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • scans007
    replied
    Originally posted by donald1234 View Post
    Your version (4.2.0) won't run on PHP 5.4 either, you need to upgrade to 4.2.2 PL1 or downgrade your PHP to 5.3.
    Again - I understand this, but I'm currently running 4.2.0 on PHP 5.4 and have been for a while with ZERO issues. What I can NOT do is upgrade to 4.2.2 PL1 as I get all the errors. The odd thing now is the admin console is telling me I'm running 4.2.2 - but I never successfully ran the upgrade script.


    Originally posted by Lynne View Post
    Did you add the line to the config.php file that Wayne asked you to in the second post? That will be needed in 4.2.2 in many cases or you will get many warnings on your site pages.
    Yes I did add the Skip param at the top of my file. I have given up - the forum somehow says I'm running 4.2.2, the forum is working and I've spent countless unsuccessful hours trying to figure it out. I'm sure I'll be back posting here when 4.2.3 is released or whatever the next version is LOL

    Thanks for everyone's help - I truly do appreciate it.
    Last edited by scans007; Tue 3rd Jun '14, 6:16am.

    Leave a comment:


  • Lynne
    replied
    Did you add the line to the config.php file that Wayne asked you to in the second post? That will be needed in 4.2.2 in many cases or you will get many warnings on your site pages.

    Leave a comment:


  • donald1234
    commented on 's reply
    php 5.4 will work with version 4.2.2 if you can figure out why it won't upgrade? The error you are getting would suggest that all the 4.2.2 files are not uploading properly, what ftp client are you using? I recommend using filezilla.

  • scans007
    commented on 's reply
    This is great to hear - but I'm confused - my site is 4.2.0 and is running perfectly on PHP5.4. Then I TRY to upgrade to 4.2.2 and it fails with these errors.

    So are you suggesting I downgrade PHP to 5.3, then try to upgrade to VB4.2.2 then re-upgrade PHP to 5.4? Just want to be clear -

    VB Support was unfortunatley zero help to me useless and didn't help me at all they asked for a FTP account which I gave them and then I couldn't get a response out of anyone for a few days - I was down for almost 3 days and just uploaded backups to get the forums back up as I have decent traffic and was getting hounded by phone, text, email, IM's......this has been really frustrating overall.

  • donald1234
    replied
    Your version (4.2.0) won't run on PHP 5.4 either, you need to upgrade to 4.2.2 PL1 or downgrade your PHP to 5.3.

    Leave a comment:


  • scans007
    replied
    Originally posted by Mark.B View Post
    4.2.2 is not actually certified for php 5.5, only php 5.4.
    This could be your issue.
    Try running php 5.4 and then run the upgrade again.

    4.2.0 can be manually patched with the instructions we provided. It's unlikely that running 4.2.0 actually caused your security breach, it's more likely to be an insecure modification or they got in through the server.
    That's what I would've thought too - but My PHP server is on 5.4.28. and it sure wasn't on 5.5 way back when I started this thread - I don't even think it existed.

    http://www.firefightcompany.com/phpinfo.php

    Any other ideas?

    With your confidence in the hacking thing - I might choose just not to upgrade once again doesn't seem like many people can help or figure whats going on with my site.

    I only have a few plugins I use - Forms, Mass PM, and a few other small ones. I'll have to investigate them. Good info!!

    Leave a comment:


  • Mark.B
    replied
    4.2.2 is not actually certified for php 5.5, only php 5.4.
    This could be your issue.
    Try running php 5.4 and then run the upgrade again.

    4.2.0 can be manually patched with the instructions we provided. It's unlikely that running 4.2.0 actually caused your security breach, it's more likely to be an insecure modification or they got in through the server.

    Leave a comment:


  • scans007
    replied
    I got hacked because I never could upgrade - I'm on version 4.2.0 trying to upgrade to 4.2.2 sp1. I did all the following
    • Disable from the config.php file: define("DISABLE_HOOKS",1);
    • Disable from the AdminCP: AdminCP > Settings > Options > Plugin/Hook System
    • Disable one by one via the Product Manager: AdminCP > Plugins & Products > Manage Products
    Fresh upload of all the files and I still get the error about 50 times on all the lines in the bitfield builder php.
    Warning: Illegal string offset 'name' in xxx/includes/class_bitfield_builder.php on line 338

    HELP!!! I don't want to bring it back up knowing I got hacked having an old version (installed/setup phishing pages on my site) but I can't upgrade, and haven't been able to since I originally posted this.

    Leave a comment:


  • scans007
    replied
    Bump - someones gotta know how to fix this!!!

    EDIT: Could this be because of PHP 5.5?
    Last edited by scans007; Mon 21st Oct '13, 4:44am.

    Leave a comment:


  • scans007
    replied
    Originally posted by Wayne Luke View Post
    In order to tell vBulletin 4.2.2 to disable all warning, notice, and error displays, you can use the class_core.php file attached to this issue: http://tracker.vbulletin.com/browse/VBIV-15862

    Upload it to the includes folder overwriting your existing file.

    Add the following line to your config.php under the <?php line:
    Code:
    define('SKIP_ALL_ERRORS', true);


    This file will only work with vBulletin 4.2.2
    Opened my config - put the definition right under the opening PHP call
    Put the class_core.phpinto my includes directory

    Uploaded both files to the server - re-ran the upgrade script but receive the same errors. Am I missing something, where should the class_core.php live (i put it in my includes folder)?

    My current version is 4.2.0 as I'm trying to upgrade to 4.2.2.

    I also see this with the Ignore and Continue button:
    Due to the following errors, the install/upgrade can not continue:
    • Following is a list of files that are either missing or contain unexpected contents. The most likely cause is that all of the files from this release have not been properly uploaded. You should resolve this error before continuing.
      /includes/class_core.php - File does not contain expected contents
    When I try to "ignore and continue" - it fails with the same errors from the first post - just in a popup.
    Last edited by scans007; Fri 18th Oct '13, 9:07am.

    Leave a comment:


  • Wayne Luke
    replied
    In order to tell vBulletin 4.2.2 to disable all warning, notice, and error displays, you can use the class_core.php file attached to this issue: http://tracker.vbulletin.com/browse/VBIV-15862

    Upload it to the includes folder overwriting your existing file.

    Add the following line to your config.php under the <?php line:
    Code:
    define('SKIP_ALL_ERRORS', true);


    This file will only work with vBulletin 4.2.2

    Leave a comment:


  • Another Upgrade issue but with the Class_bitfield_builder.php

    Here are the errors - I've never had a problem with any upgrade until this one. All I did was finally download 4.2.2, unzip - upload, and hit the upgrade.php.

    Warning: Illegal string offset 'name' in xxx/includes/class_bitfield_builder.php on line 338

    Warning: Illegal string offset 'name' in xxx/includes/class_bitfield_builder.php on line 340

    Warning: Illegal string offset 'name' in xxx/includes/class_bitfield_builder.php on line 346

    Warning: Illegal string offset 'bitfield' inxxx/includes/class_bitfield_builder.php on line 346

    Warning: Illegal string offset 'intperm' in xxx/includes/class_bitfield_builder.php on line 433

    Can anyone bail me out or give me some direction to start troubleshooting?

    Thanks so much!
    Last edited by scans007; Mon 21st Oct '13, 4:54am.

Related Topics

Collapse

Working...
X