Announcement

Collapse
No announcement yet.

Double posting after upgrading to 4.2.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Logged on Jira http://tracker.vbulletin.com/browse/VBIV-15879

    Comment


    • #17
      In order to tell vBulletin 4.2.2 to disable all warning, notice, and error displays, you can use the class_core.php file attached to this issue: http://tracker.vbulletin.com/browse/VBIV-15862

      Upload it to the includes folder overwriting your existing file.

      Add the following line to your config.php under the <?php line:
      Code:
      [COLOR=#252C2F][FONT=Helvetica][SIZE=13px]define('SKIP_ALL_ERRORS', true);[/SIZE]
      [/FONT][/COLOR]

      This file will only work with vBulletin 4.2.2

      The double-posting is another issue that has to go through the JIRA process.

      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud demonstration site.
      vBulletin 5 API

      Comment


      • #18
        You all need to vote on this issue to get it resolved.

        http://tracker.vbulletin.com/browse/VBIV-15879

        Comment


        • #19
          i am not as clued up as most of you guys but have found the errors to be coming from my add ons, i have got all of my warnings to go except for when you login or create a new article i get this

          PHP Code:
          Warning: Function split() is deprecated in ..../includes/functions_login.php(204) : eval()'d code on line 4

          Warning: Function split() is deprecated in ..../includes/functions_login.php(204) : eval()'
          d code on line 5 Redirecting... 
          all i have done was upgrade my hacks as if i disable all my add ons the errors disappear, i have found that upgrading DBtech advanced user has now caused a double post if a user tags another member, if i disable just that hack no more double posting and my members are freaking that its not working !

          i did find this but was ask to start a new thread on it

          http://www.vbulletin.com/forum/forum...ick-reply-made

          its the only thing that is really irritating as 4.2.1 seemed like it was bulletproof, is a rollback possible ?
          www.mysaltyreef.com

          Comment


          • #20
            Originally posted by Wayne Luke View Post
            In order to tell vBulletin 4.2.2 to disable all warning, notice, and error displays, you can use the class_core.php file attached to this issue: http://tracker.vbulletin.com/browse/VBIV-15862

            Upload it to the includes folder overwriting your existing file.

            Add the following line to your config.php under the <?php line:
            Code:
            [COLOR=#252C2F][FONT=Helvetica][SIZE=13px]define('SKIP_ALL_ERRORS', true);[/SIZE]
            [/FONT][/COLOR]

            This file will only work with vBulletin 4.2.2

            The double-posting is another issue that has to go through the JIRA process.
            will this fix the double posting ?
            www.mysaltyreef.com

            Comment


            • #21
              I don't thinks so, but I am glad I am not the only one experiencing this problem. Hope we getting a fix soon...

              Comment


              • #22
                Any update on the quick-reply double posting issue? I unfortunately upgraded to 4.2.2 because it was out of beta only to find out that it should never have left beta. Disabling the errors and warnings are NOT an acceptable fix.... the bug needs to be fixed.

                Comment


                • #23
                  You should apply the fix wayne psoted, it should resolve the double posting issue.

                  Comment


                  • #24
                    Originally posted by Zachery View Post
                    You should apply the fix wayne psoted, it should resolve the double posting issue.
                    so the answer is no... the error is not fixed. The only option is to hide the error?

                    i thought that wayne posted that his fix was not for double posting (last line in his post)

                    Comment


                    • #25
                      Originally posted by shots View Post

                      so the answer is no... the error is not fixed. The only option is to hide the error?

                      i thought that wayne posted that his fix was not for double posting (last line in his post)
                      It depends on what's causing it. There can be various causes of double posts.

                      Try the workaround that was posted.....if that clears the problem, then the cause will have been a php warning.
                      MARK.B | vBULLETIN SUPPORT

                      TalkNewsUK - My vBulletin 5.6.3 Demo
                      AdminAmmo - My Cloud Demo

                      Comment


                      • #26
                        If you weren't getting double-posts in 4.2.1, but are getting them in 4,2,2, it is almost definitely caused by warning messages being generated that you simply don't see and Wayne's posted fix should clear that.Therefore I strongly suspect hiding warnings will prevent the double-posting issue *IF* it was new to 4.2.2. Also make sure you have disabled all your add-ons to see if it is the result of a warning/error from an add-on.

                        Comment


                        • #27
                          Looks like this fix did the trick for my 4,2,2 site.

                          Thanks.

                          Comment


                          • #28
                            I tried using the config.php and client script workarounds but still get the dialog about leaving the page. I voted - and hope this is in 4.2.3

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X