Announcement

Collapse
No announcement yet.

Error after upgrading to 4.2.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • kushal
    replied
    Same error here in this thread: http://www.vbulletin.com/forum/forum...ade-php-5-4-17

    here is the message:

    Warning: mktime(): You should be using the time() function instead in ..../includes/class_core.php(4715) : eval()'d code on line 1

    Tried the option given to create a new plugin, didnt work.
    Tried editing the files, didnt work. This files:
    "You can try to change mktime() and gmmktime() to time() in includes/functions_ad.php and includes/functions_notice.php."

    However, these errors go away when notice and ads are disabled.

    Any help?

    Leave a comment:


  • Allthumbz
    replied
    I could not even get into ADMINCP to disable hooks! I got the errors below and it locked. What do I do now?


    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../dbtech/vbdonate/hooks/global_bootstrap_init_complete.php on line 44

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 4912

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 5104

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 5104

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 5104

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../dbtech/vbdonate_pro/hooks/global_start.php on line 23

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 5104

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 5104

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../dbtech/vbdonate_pro/hooks/parse_templates.php on line 16

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../dbtech/vbdonate/hooks/parse_templates.php on line 25

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../dbtech/vbdonate/hooks/parse_templates.php on line 34

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../dbtech/vbdonate/hooks/parse_templates.php on line 239

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../dbtech/vbdonate/hooks/parse_templates.php on line 249

    Warning: date() [function.date]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EDT/-4.0/DST' instead in ..../includes/functions.php on line 5104
    Unable to add cookies, header already sent.
    File: /home/hobbymac/public_html/includes/class_core.php
    Line: 5745

    Leave a comment:


  • Recep Baltaş
    replied
    Still getting some errors after updating or editing posts.

    Leave a comment:


  • Recep Baltaş
    replied
    Thanks for the help Joe. All of the problems were gone. Yo can login to adminCP and theck the modifications whenver you want.

    Leave a comment:


  • Joe D.
    replied
    OK, I see your support ticket, I added this plugin to your template_render_output hook that should clear the warning for now. I will need to follow up with why you get this error, when i logged into your forum I saw mods were disabled and the template is default already.

    PS, if anyone else comes across this issue the plugin code is-
    Code:
    if (!$actioned)
    {
      $template_code = self::fetch_template($this->template);
      $template_code = str_replace ('gmmktime' , 'time' , $template_code);
      $actioned = true;
    }

    Leave a comment:


  • Recep Baltaş
    replied
    I have diabled the hooks and the problem was still there. I am already using the default style. I have created another style but it did not work either.

    Leave a comment:


  • Joe D.
    replied
    This error is due to template code being evaluated, since it doesn't happen in the default install it is likely due to a 3rd party mod or custom template code. It is a bit confusing as the function gmmktime shouldn't even be allowed in template code.

    Please fist disable hooks and see if the warning goes away. - http://www.vbulletin.com/forum/forum...ystem-globally

    If it doesn't, keep hooks disabled ad try the default style-

    Let us know if either makes the warning go away.

    To get the default style go to Admin CP -> Styles & Templates -> Style Manager -> Add New Style and create a new style with no parent style. This will be the default style.

    Then go to Admin CP -> Settings -> Options -> Style & Language Settings and give permission for users to change styles (if it was disabled) so you can change to the default style to test it.

    Leave a comment:


  • Recep Baltaş
    replied
    Messed up the whole thing. Real good job on QA guys. real good job. Now I understand that we were not waiting for the QA, we were waiting for your pleasure...



    Also:

    Leave a comment:


  • Recep Baltaş
    started a topic [Forum] Error after upgrading to 4.2.2

    Error after upgrading to 4.2.2

    Hi guys, after upgrading to 4.2.2, I am getting this error on the top of the forum:

    Warning: gmmktime() [function.gmmktime]: You should be using the time() function instead in ..../includes/class_core.php(4715) : eval()'d code on line 1

    My board is using Turkish language. My plugins as below. Disabled, same...
    Başlık Versiyon Ašıklama Kontroller
    vBulletin 4.2.2
    GlowHost - Spam-O-Matic 2.1.2 Ultimate solution to defend against SPAM: Check new registrations from StopForumSpam database, auto moderate posts against custom word-list and Akismet service.
    Minimum number of posts to send pm. 1 It will set a minimum number of posts for your users in order to send pm.
    More Share Options TNG by BOP5 (Free Version) 3.2 Add more "Share" buttons to all forum pages.
    Tapatalk 4.7.2 Tapatalk mobile app plugin for vb4.
    vBSEO 3.6.1 vBulletin SEO
    vBSEO :: Sitemap Generator 3.0 Generate a Google & Bing Sitemap for your Forums
    vBulletin Blog 4.2.2 Personal web log, integrated with vBulletin.
    vBulletin CMS 4.2.2 Content Management System

    And my time settings:
    Last edited by Recep Baltaş; Wed 9th Oct '13, 3:01am.

Related Topics

Collapse

Working...
X