Announcement

Collapse
No announcement yet.

Message Editor doesn't register line breaks by pressing Enter key in Internet Explorer unless switched to Source mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • chrisngrod
    replied
    I know this is a little old, but try editing the headinclude.

    List it at the very top... ie...

    <meta http-equiv="X-UA-Compatible" content="IE=9" />
    <meta http-equiv="Content-Type" content="text/html; charset={vb:stylevar charset}" />
    <meta id="e_vb_meta_bburl" name="vb_meta_bburl" content="{vb:raw vboptions.bburl}" />
    <base href="{vb:raw basepath}" /><!--[if IE]></base><![endif]-->...

    I refreshed the thread I was viewing and then went to another thread to actually test it.

    Leave a comment:


  • too_cool_3
    replied
    I do have Tapatalk installed but I'm not sure if that is the cause of this error.

    Leave a comment:


  • Thunderbird
    replied
    I remember there used to be a sticky about Tapatalk (and at least one other addon) causing the <META> line to be placed too low (and thus not read by IE). I don't know where that sticky went, and I can't remember the solution for that if it is indeed the problem.

    Leave a comment:


  • hurricane_sh
    replied
    It should work. 4.2.2 fixed the problem by adding the same code, are you sure you added it correctly?

    Leave a comment:


  • macribas
    replied
    Originally posted by hurricane_sh View Post
    Only IE 10 as far as I know, add the following line to your header template:

    <meta http-equiv="X-UA-Compatible" content="IE=9" />
    Didn't work for me... any other suggestions?

    Leave a comment:


  • hurricane_sh
    replied
    Only IE 10 as far as I know, add the following line to your header template:

    <meta http-equiv="X-UA-Compatible" content="IE=9" />

    Leave a comment:


  • too_cool_3
    replied
    Are there any other browsers affected by this issue or only IE10?

    Leave a comment:


  • Zachery
    replied
    No, I uses a newer version of Ckeditor that does not suffer from the issue

    Leave a comment:


  • too_cool_3
    replied
    Thanks Zachery. Does vB 5 have this issue?

    Leave a comment:


  • Zachery
    replied
    This is a known issue. It is currently unlikely to be fixed in a recent build do to the insanely high level of effort required to fix.

    Leave a comment:


  • Message Editor doesn't register line breaks by pressing Enter key in Internet Explorer unless switched to Source mode

    Hi,

    I'm running vB 4.2.1 and Internet Explorer 10. The vB message editor (regardless if it is Quick Reply or Advanced or using Enhanced Interface, Basic Editor or Standard Editor) does not allow me to enter a line break (by pressing the Enter button) unless I switch to Source Mode - then it works fine. I have tested this in FireFox and am not experiencing this issue. Only running IE and am able to reproduce this on two separate machines, one running Win7 the other Win8.

    Warm regards,

    Marc
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X