Style lost. Blank pages, parse errors, images not shown after site hacked

  • Time
  • Show
Clear All
new posts
  • Guest

    Style lost. Blank pages, parse errors, images not shown after site hacked

    Hello everybody.

    My site was hacked. Some files were uploaded, admin created, as well as plugins and stuff. I deleted everything and updated to the last version (4.2.1.) The problem is that the template I was using was damaged: blank pages, no images, parse errors and stuff, so I changed to the default vbulletin style.

    Everything was ok, but, Yesterday I tried to import the style damaged to my site, in order to have it like it was before the attack. Despite of working properly, after uploading my custom style, the default shows the same problem: no images, parse errors... It is like the default style has been "infected" or something like that.

    I have tried to revert all the templates and it didn't work. I've also tried to create a new default style from the beginning and it doesnt work neither.

    The only way to make my site running fine is using the mobile template...

    I've compared the templates of the styles for Desktop PC and mobile devices and there is a difference:

    Desktop PC:


    There are less templates in the Desktop style. Is that correct? How do I fix this mess? Can the the DB damaged too?

  • Guest

    Even the style generator seems to be with broken paths. Could be this a paths problem?


    • Lynne
      Former vBulletin Support
      • Oct 2004
      • 26255

      Can you upload tools.php from your do_not_upload directory into your admincp and point your browser at it, login, and then click to Rebuild Master Style.

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools <- awesome site for html/css help


      • Guest

        When trying to access the file after uploading it, the browser shows:

        Warning: require_once(./install/includes/class_upgrade.php) [function.require-once]: failed to open stream: No such file or directory in [path] on line 46

        Fatal error: require_once() [function.require]: Failed opening required './install/includes/class_upgrade.php' (include_path='.:/usr/lib/php5') in [path] on line 46

        This seems serious... Thanks!


        • Amaury
          Senior Member
          • Mar 2012
          • 1807
          • 4.2.X

          I would send in a support ticket with Admin CP and FTP information,
          Former vBulletin user


          • Guest

            I cant send tickets. Thanks.


            • Guest

              Could anyone help me with the php errors? Thanks!


              • Guest



                Related Topics


                • Mevlüt Akpinar
                  Error :API Error
                  by Mevlüt Akpinar
                  Etc. 5 I smoke. I do not have a shortage of time following entry but I also enter my login information (in debug mode) I get the following errors.

                  Error :API E...
                  Tue 22 Dec '15, 1:42pm
                • avitor
                  sitemap not shows
                  by avitor
                  why i get this when i try to view sitemap after build sitemap ?
                  this message shows just after completed sitemap build
                  Sitemap built successfully. You may view the XML here.
                  and when
                  Wed 3 Feb '16, 4:57pm
                • geovadim
                  Update errors
                  by geovadim
                  I am trying to update my forum vb3.7 to vb5 connect. I've copied the files from vb5 in a test forum and created a copy of the live database.

                  PHP Version 5.4.38

                  I went to upgrade...
                  Mon 2 Mar '15, 3:18am