Announcement

Collapse
No announcement yet.

Session lost when adding 'www.' to the URL?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dougdirac
    replied
    Normally people do it the other way around (and with a redirect) but that's fine.

    Leave a comment:


  • FSM
    replied
    As an update all seems to be well. I also wrote a little javascript code to check if they typed "www." in the url, and redirect them to the same location without the "www.".

    Leave a comment:


  • FSM
    replied
    Thanks for the response Wayne. I'll see if this resolves all my issues.

    Leave a comment:


  • Wayne Luke
    replied
    For the invalid redirect message go to Settings -> Options -> Site Name / URL / Contact Details and place the troublesome URL in the Redirect Domain Whitelist box.

    Sessions can be lost when going from www to none-www due to how browsers treat cookies. Technically they are seen as different servers and even websites. They don't even need to be the same machine and can be in two different physical locations in the world.

    Leave a comment:


  • FSM
    started a topic Session lost when adding 'www.' to the URL?

    Session lost when adding 'www.' to the URL?

    Hello,

    I was encountering an issue where some of my users were getting an "Invalid redirect" message after logging in, so I adjusted my vbulletin url setting to not use the forum url as the base path. That fixed that issue. The problem then though was my dbtech arcade system doesn't render games correctly unless a "www." is in the domain. So I adjusted the link to the arcade to put a "www." in the url. The problem now is, the session becomes lost and the user has to log back in.

    Does anyone know how to make a session keep alive from say d1jsp.org to www.d1jsp.org?

    Thanks in advance,
    -Andy

Related Topics

Collapse

Working...
X