No announcement yet.

[vB4.2.1] 404 Error and possible DDoS

  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] [vB4.2.1] 404 Error and possible DDoS

    Hello my site appears to now give me a 404 Error with "The requested URL /install/install.php was not found on this server." I don't know why and I cannot recall that I tampered with the www ftp files or messed around with AdminCP. My site got some 3rd party addons or plugins from vBadvanced and DBTech as well as Spam-O-Matic. I've been getting a lot of spambots and its usually up to my Spam-O-Matic to block and auto-moderate my posts that is considered spam and maybe the cause of my site broken down. I do use Google's reCAPTACHA but I don't know how to alter my registration options only allow a slightly stronger password strength to avoid weak passwords and maybe restrict wannabe spambot hackers. I've changed my FTP password and checked if install.php is deleted or not to avoid any disasters.

    I've contacted my host as I appear to have a MySQL error.

    Can you maybe help me out, please?

  • #2
    The system will redirect to the install file, it it can't access the datastore. I'd suggest making sure your MySQL database is complete and not missing any tables, or them being crashed.


    • #3
      I see. I've just backed up the database from yesterday, today and last week. I tried using phpMyAdmin and used Optimized and Repair on all of the tables. But not luck what so ever, and my host been notified on this problem. Is there any other key tips on phpMyAdmin that may eliminate any missing or corrupt tables?


      • #4
        Was the datastore table present?


        • #5
          I'm not sure what that means nor how I find that.
          Last edited by RoboCop1985; Tue 3rd Sep '13, 5:23am.


          • #6
            You can look to see if the datastore table exists in the DB using phpmyadmin, which you said you accessed in your previous posting.
            Gentoo Geek


            • #7
              OK I've checked in the datastore and it appears to have most of the tables like vsa_ppdonate and pt_user with 108 more are there. And used check, repair and optimised the tables but not worked so far. I got the backup dmp in my PC that I backed up from last week and yesterday if those are useful.


              • #8
                After following the host server's advice to remove vbseo because it was causing cpu resource overloads on the shared server, I've created a similar problem. I can get the forum main page, and pages like [subscribed threads] and [today's posts] but clicking on any link brings a 404 error. I tried repair & optimise tables and got a long list of OKs, but also this:
                Database error in vBulletin 4.2.0:

                Invalid SQL:
                OPTIMIZE TABLE `wfvb_post`;

                MySQL Error : MySQL server has gone away
                Error Number : 2006
                Request Date : Friday, September 13th 2013 @ 11:49:14 PM
                Error Date : Friday, September 13th 2013 @ 11:50:18 PM
                Script :
                Referrer :
                IP Address : [*removed*]
                Username : Cran
                Classname : vB_Database
                MySQL Version :
                From what I can find in searches, I was supposed to follow up the seo-linked file removals with a rewrite, such as:

                RewriteEngine On
                RewriteRule ^members/([0-9]+) member.php?u=$1&%{QUERY_STRING}
                RewriteRule ^list/([^/]*/)([0-9]+) list.php?r=$1$2&%{QUERY_STRING}
                RewriteRule ^content/(.*) content.php?r=$1&%{QUERY_STRING}
                RewriteRule ^threads/([0-9]+)-(.*)? showthread.php?t=$1 [QSA,L]
                RewriteRule ^members/([0-9]+)-(.*)? member.php?u=$1 [QSA,L]
                RewriteRule ^forums/([0-9]+)-(.*)? forumdisplay.php?f=$1 [QSA,L]
                RewriteRule ^entries/([0-9]+)-(.*)? entry.php?t=$1 [QSA,L]
                RewriteRule ^blogs/([0-9]+) blog.php?u=$1&%{QUERY_STRING}
                - and that it has something to do with Apache. I've looked everywhere I can think of but I cannot find Apache either in the Admincp or the server cPanel.

                Right now, I am the inexperienced and computer-illiterate owner of a forum that its 2000 plus members can't use. Any help will be gratefully received.


                • #9
                  Simply remove vbseo related stuff from your .htaccess file, or Apache main config file if you don't use htaccess.


                  • #10
                    Hi hurricane_sh.
                    If the .htaccess file was in the install file, it (the install file) was deleted before I found myself landed with the forum (long story). I've removed everything related to the vbseo, but -
                    I cannot find Apache either in the Admincp or the server cPanel.
                    - to insert the rewrite code that is supposed to redirect everything that was going through vbseo. I'm now trying to find out if I can get Apache from somewhere and install it, although from what little I've read about it, it's a more complex operation than I can comfortably handle. I'm hoping that by going through the steps, I can find out where Apache is supposed to be, and therefore if it is there; if not, then I should probably proceed with the installation.

                    ETA: The cPanel tells me that Apache 2.2.24 is there, but not where to find it. The internal search provides only two small txt documents each with a few lines of code.
                    Last edited by Cran; Sat 14th Sep '13, 1:50am. Reason: Further info


                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.