Announcement

Collapse
No announcement yet.

HELP! Forum keeps switching me to different users on every page refresh

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP! Forum keeps switching me to different users on every page refresh

    I am running vB 4.1.7. I just installed yesterday.

    My board was/has been loading pages really slow despite me just upgrading my VPS service Sunday. I was receiving Errors about MySQL going away and I came across this ---> https://www.vbulletin.com/forum/show...rror-explained and sent the info to my host for them to apply this and they contacted me and said that they had done what was mentioned.

    Afterwards, every time I would refresh a page or click to another part of my forum/message board I am changing to a different user. It took a lot of luck for me to be able to get into my Admin Panel and Shut Down the forum. I have different style per forum and sometimes the style would change to something it shouldn't and can't depending on the forum I would log into.

    I am completely baffled. I sent an Email to my hosts support. I was wondering if anyone could help me on this end.

    Thanks
    Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
    Twitter - @pghsportsforum
    Facebook - www.facebook.com/pghsportsforum

  • #2
    Are all your users, including yourself, behind the same proxy server?

    The only way this would happen is if you're not using cookies in your browser and you're all behind the same proxy server. Used to be a big issue with AOL users years ago but we really haven't heard of this happening recently. Not since cookie adoption has gone up to almost 100%.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
    vBulletin 5 Documentation - Updated every Friday. Report issues here.
    vBulletin 5 API - Full / Mobile
    I am not currently available for vB Messenger Chats.

    Comment


    • #3
      I'm not really sure why we would be behind a proxy server? I cleared cookies in my browser except for Active Logins, Site Preferences. Should I clear those as well?
      Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
      Twitter - @pghsportsforum
      Facebook - www.facebook.com/pghsportsforum

      Comment


      • #4
        I went through and did those additional cookie clearing preferences and no changes. With my forum in maintanence mode and if I log out, I back in and then its directly going to a different user as soon as the login goes through. Very strange but also gives someone the ability to try and login and end up logging in with me
        Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
        Twitter - @pghsportsforum
        Facebook - www.facebook.com/pghsportsforum

        Comment


        • #5
          bump
          Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
          Twitter - @pghsportsforum
          Facebook - www.facebook.com/pghsportsforum

          Comment


          • #6
            What is the address to your site?
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
            vBulletin 5 Documentation - Updated every Friday. Report issues here.
            vBulletin 5 API - Full / Mobile
            I am not currently available for vB Messenger Chats.

            Comment


            • #7
              www.pittsburghsportstavern.com

              I have it currently turned "off". Let me know what you need.
              Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
              Twitter - @pghsportsforum
              Facebook - www.facebook.com/pghsportsforum

              Comment


              • #8
                I am having AN issue where I try to login to the Admin CP and I get to the "Redirecting... Thank you for logging in" and then it takes me right back to the login screen, I am also getting this error
                Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
                Twitter - @pghsportsforum
                Facebook - www.facebook.com/pghsportsforum

                Comment


                • #9
                  Bump
                  Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
                  Twitter - @pghsportsforum
                  Facebook - www.facebook.com/pghsportsforum

                  Comment


                  • #10
                    Please reset your cookie path and cookie domain variables. These should not be set unless you have multiple vBulletin installations on the same domain name. You can reset these using tools.php.

                    Follow these steps.

                    1) Upload tools.php from your "do_not_upload" folder. This should go into your admincp directory.

                    2) Load this in your browser by going to: yourforums/admincp/tools.php

                    3) Enter your customer ID.

                    4) Click on Reset Cookie Path and Reset Cookie Domain.

                    5) Delete tools.php from your server.

                    6) See if you can login.

                    Also repeatedly bumping your posts really doesn't accomplish anything. We try to help everyone equally.
                    Translations provided by Google.

                    Wayne Luke
                    The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                    vBulletin 5 Documentation - Updated every Friday. Report issues here.
                    vBulletin 5 API - Full / Mobile
                    I am not currently available for vB Messenger Chats.

                    Comment


                    • #11
                      Ok, that worked, I was able to log into my Admin CP. I still am having issues where my styles aren't rendering on the forums that they are supposed to. I have my "main" style basically overriding any of the other ones and the ones it is overriding aren't for forums that people have the option to change. I also am trying to "break" the board so to speak to see if the issue with the forum switching my account to other members occurs. It has continuously occurred but I'm not sure exactly what is triggering it
                      Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
                      Twitter - @pghsportsforum
                      Facebook - www.facebook.com/pghsportsforum

                      Comment


                      • #12
                        Ok, the issue with the forum changing me over to another member came back. Basically it seems to happen when I click on any Button/Link that takes me back to the Forum Home (index.php). When this happens it takes me to the "maintenance mode" message and it shows some other random Member who is most likely someone that just tried to log in. If i goto to my vBa CMS from this point, it shows me as being logged in and I can then access all of my other forums as "me" except if I try to do anything to access the Main forum (index.php).
                        Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
                        Twitter - @pghsportsforum
                        Facebook - www.facebook.com/pghsportsforum

                        Comment


                        • #13
                          The issue with not being able to login to the Admin CP has popped up again. All I am doing is randomly going from forum to forum (surfing through the forum as it is in maintenance mode) until something wrong occurs. If it's not me getting swapped with a regular member's account, then I can't log in to the Admin CP. It's one or the other. I get one problem to disappear briefly but the other one pops back up
                          Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
                          Twitter - @pghsportsforum
                          Facebook - www.facebook.com/pghsportsforum

                          Comment


                          • #14
                            Really have no idea what you're doing but I am guessing you have a problem with an addon or a custom style. You'll need to reset the cookies like you did before and turn the forums back on. Don't do anything else until we can look at it.
                            Translations provided by Google.

                            Wayne Luke
                            The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                            vBulletin 5 Documentation - Updated every Friday. Report issues here.
                            vBulletin 5 API - Full / Mobile
                            I am not currently available for vB Messenger Chats.

                            Comment


                            • #15
                              I am currently at this moment in time, able to log in to the Admin CP. I'm leaving all be. Let me know what you need from me
                              Pittsburgh Sports Forum | http://www.pghsportsforum.com/forum
                              Twitter - @pghsportsforum
                              Facebook - www.facebook.com/pghsportsforum

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X