Announcement

Collapse
No announcement yet.

Problem with HTML

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [CMS] Problem with HTML

    The stream host I am using for my online radio has code for displaying things like the current song, a request form, etc... The only downside is that it has the main code and then has code that needs to be placed before the </body> tags. The thing is, I place all that code into the text edit box and it doesn't work out. For example, the request form. The form is there but whenever you click submit, it does not do anything. Here is the page where the form is located- http://allmjradio.com/content.php?9-Listen-Live

  • #2
    JavaScript will require you to refresh the page once you make changes via AJAX (like creating or editing content.)

    I just went to your link, put in a request, and got the "thank you" alert that is was submitted.

    I think it's working.

    Comment


    • #3
      Joe? Requested frank s. or something stupid?

      Originally posted by BirdOPrey5 View Post
      JavaScript will require you to refresh the page once you make changes via AJAX (like creating or editing content.)

      I just went to your link, put in a request, and got the "thank you" alert that is was submitted.

      I think it's working.

      Comment


      • #4
        Yup... That is my guy.

        Click image for larger version

Name:	frankie.gif
Views:	1
Size:	1.6 KB
ID:	3685691

        Comment


        • #5
          Haha . So basically I have to wait for it all to refresh? And also, all the forms require a code to be placed at the bottom. The thing is, it is all the same code. Do I have to put the code at the bottom for each form? Or will just once be good?

          Originally posted by BirdOPrey5 View Post
          Yup... That is my guy.

          Comment


          • #6
            Put the code in your footer template, at the very bottom. That will make sure it loads on every forum powered page.

            I think it will work right from now on- it was just the first time you added the HTML you had to refresh the page before trying to use it.

            I'm listening to music from it right now.

            Comment


            • #7
              Thanks for listening . I just added another form (stream title, name, etc.) and it is not doing anything but sitting there. I am guessing it will take a few minutes also?

              Originally posted by BirdOPrey5 View Post
              Put the code in your footer template, at the very bottom. That will make sure it loads on every forum powered page.

              I think it will work right from now on- it was just the first time you added the HTML you had to refresh the page before trying to use it.

              I'm listening to music from it right now.

              Comment


              • #8
                No that one looks like it's not loading at all... Was there additional codes you needed to place elsewhere?

                Comment


                • #9
                  Here is the code for the main body of it:
                  Current song: <a href="http://viadj.viastreaming.net/tunein.php/allmjradio/tunein.pls" id="cc_stream_info_song">Loading...</a><br />
                  Stream title: <span id="cc_stream_info_title"></span><br />
                  Bit rate: <span id="cc_stream_info_bitrate"></span><br />
                  Current listeners: <span id="cc_stream_info_listeners"></span><br />
                  Maximum listeners: <span id="cc_stream_info_maxlisteners"></span><br />
                  Server status: <span id="cc_stream_info_server"></span><br />
                  Source status: <span id="cc_stream_info_source"></span><br />

                  And here is the code that is placed at the bottom of that page:
                  <script language="javascript" type="text/javascript" src="http://viadj.viastreaming.net/system/streaminfo.js"></script>
                  <script language="javascript" type="text/javascript" src="http://viadj.viastreaming.net/js.php/allmjradio/streaminfo/rnd0"></script>

                  Comment


                  • #10
                    That 2nd line of JavaScript - the very last line, are you sure that is correct? it doesn't seem to be adding any necessary code.

                    Comment


                    • #11
                      To be honest, I'm not completely sure. I am just copying the code from my admin control panel. If it would make a big difference, I will contact my host to see if it is needed?

                      Originally posted by BirdOPrey5 View Post
                      That 2nd line of JavaScript - the very last line, are you sure that is correct? it doesn't seem to be adding any necessary code.

                      Comment


                      • #12
                        Did you get the music player from your host? That seems unusual. I would contact whoever is the author of the music system you are using.

                        Comment


                        • #13
                          While I contact my host, here is a page where that form is working. http://allmjradio.com/streaminfo.php. Must have something to do with the page on my site.

                          Originally posted by BirdOPrey5 View Post
                          Did you get the music player from your host? That seems unusual. I would contact whoever is the author of the music system you are using.

                          Comment


                          • #14
                            Sorry last edit I promise...

                            The problem is the two JavaScripts you say are at the bottom of the page just aren't there.

                            Code:
                            <script language="javascript" type="text/javascript" src="http://viadj.viastreaming.net/system/streaminfo.js"></script>
                            <script language="javascript" type="text/javascript" src="http://viadj.viastreaming.net/js.php/allmjradio/streaminfo/rnd0"></script>

                            Where exactly did you add them? Maybe in a different style?
                            Last edited by Joe D.; Sat 15 Oct '11, 1:49pm.

                            Comment


                            • #15
                              Just posting because I edited my previous post several times... what is there now is the latest version.

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X