Announcement

Collapse
No announcement yet.

Pruning users is considerably slow.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ion Saliu
    replied
    Axiomatic Colleague of Mine:

    I felt the same pain! I first wrote about it in this thread:

    https://www.vbulletin.com/forum/show...ers-in-AdminCP
    “vBulletin 4.1.12PL1; before upgrading, I decided to bulk-remove a bunch of suckers from the members of my forums. I tried vis AdminCP, Users, Prune / Move Users. I applied one criterion and the system returned some 1200 users. I made sure all were selected in the checkboxes.

    I checked Delete, then I pressed Go. The mouse pointer jumps a few spaces, but nothing really happens. I waited for minutes, but it doesn’t appear to be any activity.”
    Then other administrators had the same frustrating experience. Last time I wrote about it:

    https://www.vbulletin.com/forum/show...ers-in-AdminCP

    In my experience, I wasn't able to delete 1000 or more users in a batch. Now, my forum is not that old (since September 2010). I started pruning when the number of “members” reached 13,000. I realized that 90% of them were spammers.

    There is a failed business on the Internet to create user profiles in many, many forums. The scammers “think” that the search engines would improve a website’s ranking because there are lots of backlinks pointing to the website. NOT! Au contraire, Google started to severely punish the websites who resort to such SEO tactics!

    I’m pretty sure now that 75% to 90% of all users, in any forum in the world, are spammers created mainly by spambots.

    So, I resolved my problem by setting the days without a login to 1000 the first time. If your forum is very old, figure out its age in days. Set days without a login to the age of your forum. Hopefully, you’ll get a number of total users under 1000. If not, try first one group at a time. Start with users awaiting email verification; then banned users

    It is very easy for me now, as I keep total members under 1000. I just did a pruning operation before posting this reply.

    Best of luck to you all, admins struck by the spambot flood!

    Ion Saliu
    VeeBeer Forum Administrator At-Large
    “A good man is an axiomatic man; an axiomatic man is a happy man. Be axiomatic!”

    Leave a comment:


  • JamPal
    replied
    Does anyone know a way of filtering users and deleting them?

    The Prune feature does not work at all for this many users.

    Leave a comment:


  • JamPal
    replied
    How does one prune only spam bots though?
    .
    Thee seems to be no way of selecting people based on the date they accepted our rules.
    Last edited by JamPal; Wed 4th Dec '13, 11:52pm.

    Leave a comment:


  • Zachery
    replied
    Pruning users removes a LARGE amount of data, so it can't go all that quickly, I'd do smaller batches, until you find a number that goes quickly, and doesn't time out/kill the server.

    Leave a comment:


  • mentalrz
    replied
    Originally posted by Walt Gekko View Post
    I have the same problem. I'm trying to prune a ton of bots from my board (over 375,000). Is there a way I can do that more efficiently (i.e.: Not get errors or timeouts after deleting 20 or so users) or do I need to simply do a complete re-install the board and start over (copying any important posts first and then re-posting as many of them as possible)?
    I'm still waiting for a reply.

    Leave a comment:


  • Walt Gekko
    replied
    I have the same problem. I'm trying to prune a ton of bots from my board (over 375,000). Is there a way I can do that more efficiently (i.e.: Not get errors or timeouts after deleting 20 or so users) or do I need to simply do a complete re-install the board and start over (copying any important posts first and then re-posting as many of them as possible)?

    Leave a comment:


  • mentalrz
    replied
    Slow replies too? Bump

    Leave a comment:


  • mentalrz
    started a topic [Forum] Pruning users is considerably slow.

    Pruning users is considerably slow.

    Hi

    I'm trying to prune around 150,000 users but when I run a test on 50 users only to delete a single user takes 20 seconds. Any suggestions on what is causing this because I'm finding vBulletin rather temperamental when it comes to such large tasks.

    Thanks.

Related Topics

Collapse

Working...
X