Announcement

Collapse
No announcement yet.

New Forum - Everything working except registration. Database Error.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Levelbest
    replied
    Thanks for trying to help me snakes - most appreciated. I'm filing a ticket.

    Leave a comment:


  • snakes1100
    replied
    If this is a totally stock install after the impex import, then i would suggest letting vb support look at this point.

    You can also try a old myisamchk -o vb_userfield* on that table from the cmd line.

    Leave a comment:


  • Levelbest
    replied
    I don't believe I have phpmyadmin installed. I've never used it in all the years I've run vbulletin.

    I looked in MySQL admin and the auto increment box is unchecked for that field

    Leave a comment:


  • snakes1100
    replied
    phpmyadmin has a field listed as extra, if you view the structure tab for that table, as that field shouldnt autoincrement.

    Leave a comment:


  • Levelbest
    replied
    Yeah, if you look at the last error - all those fields were deleted. And after that I deleted those after the first 4.

    Not sure what you mean re: extra settings. I look at my database thru MySQL Administrator

    Leave a comment:


  • snakes1100
    replied
    The userid field shouldnt have a "extra" settings on it, does it show an "autoincrement" on it in phpmyadmin, when looking at the structure of the table?

    Im not sure if u did, but the extra 60 fields that vb didnt import a value for can be removed, vb by default only has 4 until you add more in the admincp

    Leave a comment:


  • Levelbest
    replied
    Disabled all human verification - error persists. The user I am registering shows up in the USER list but the registration email never goes out as well.


    Code:
    Database error in vBulletin 4.2.1:
    
    Invalid SQL:
    INSERT INTO vb_userfield
    (field6, field7, field8, userid)
    VALUES
    ('', '', '', 1061);
    
    MySQL Error   : Duplicate entry '1061' for key 1
    Error Number  : 1062
    Request Date  : Saturday, July 13th 2013 @ 03:06:15 PM
    Error Date    : Saturday, July 13th 2013 @ 03:06:15 PM
    Script        :
    Referrer      :
    IP Address    :
    Username      : lbemb
    Classname     : vB_Database
    MySQL Version :

    Leave a comment:


  • Levelbest
    replied
    No hacks installed at all - running captcha for human verification.

    Leave a comment:


  • snakes1100
    replied
    I assume you have no hacks installed on that forum at this point that relates to registration?

    Disable all your hacks if you do & as well as the default human verification's that vb provides.

    Leave a comment:


  • Levelbest
    replied
    I checked registered users and the last registered user was the final import from UBB - (id: 1054)

    Leave a comment:


  • Levelbest
    replied
    The last imported user from UBB was (id: 1054)

    Leave a comment:


  • Levelbest
    replied
    I have tried registering 4-5 times now. Each time, the userid increments and says there is a duplicate.

    Leave a comment:


  • snakes1100
    replied
    Did you verify that you have a userid already of 1055?

    Leave a comment:


  • Levelbest
    replied
    I've actually run a repair/optimize on all fields both thru the admin side of the boards and the MySQL admin on the site. Still having the issue...

    BTW, prior to importing the UBB users, I had a friend register and it worked...
    Last edited by Levelbest; Sat 13 Jul '13, 11:49am.

    Leave a comment:


  • snakes1100
    replied
    Run a repair on the db table named vb_userfield

    Leave a comment:

Related Topics

Collapse

Working...
X