Announcement

Collapse
No announcement yet.

IP address showing up instead of domain name

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] IP address showing up instead of domain name

    Ok so I installed vbulletin 4, when i had no domain name, just an IP address on my VPS. Now I pointed my domain to my VPS ip address, which works when I go to www.domainname.com/forums but everything else I click after wards is IPAddress/fourms/showthread... How do I change it to show only domain name instead of IP address? I am running CentOS btw.

    Thanks for any help

  • #2
    In Admin CP -> Options -> Site Name / URL / Contact Details


    You probably need to update your forum url.

    Comment


    • #3
      Originally posted by BirdOPrey5 View Post
      In Admin CP -> Options -> Site Name / URL / Contact Details


      You probably need to update your forum url.
      Hi that works, but it has given me another problem. All the images on the forum do not work anymore after the change. Do I have to change anything in Apache?

      Thanks.

      Comment


      • #4
        Originally posted by illproducer View Post
        Hi that works, but it has given me another problem. All the images on the forum do not work anymore after the change. Do I have to change anything in Apache?

        Thanks.
        Silly question but is the domain assigned to the server, is the DNS set correctly, did you check the DNS bind. It sounds like vb is looking for the images @ domain/image path, but they're @ IP/image path...
        www.cdmagurus.com
        www.cellphone-gurus.com

        Comment


        • #5
          Originally posted by illproducer View Post
          Hi that works, but it has given me another problem. All the images on the forum do not work anymore after the change. Do I have to change anything in Apache?

          Thanks.
          I'm not sure what browser you are using, on Chrome and others you can right click on an image (or broken image) and choose "Copy Image URL" - on Internet Explorer you right click on an image and go to "Properties" and the URL to the image will be there, you can copy it if you highlight it with the mouse.

          What is the URL to the broken image? Any images will do... If it's your IP and you don't want to share it just change the numbers. That will give some idea what it's looking for.

          Another option is in the same place as the forum URL setting see what you have: Always use Forum URL as Base Path set to, and change it to the other setting. Might be a work-around if not an actual fix.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X