Announcement

Collapse
No announcement yet.

URL Differences and Redirects

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • italynstylion
    replied
    I think that fixed it! I had to create my own file since one didn't exist already (like you said). I had to modify the code that apache recommended a little bit to make it work. here's what I ended up using....
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/forum [R=301,L]


    Thanks for all the help!

    Leave a comment:


  • BirdOPrey5
    replied
    .htaccess is either in your website root directory or your /forum/ directory. If it is in the forum root is affects all folders below it, if it is in /forum/ it affects /forum/ and any folders below that.

    If it doesn't exist (it does not by default in vBulletin 4.x) you can create your own, it is a plain text file called .htaccess

    Leave a comment:


  • italynstylion
    replied
    Still can't find this .htaccess file. What directory is it supposed to be in? Is this something I need to create from scratch?

    Leave a comment:


  • italynstylion
    replied
    Where is the .htaccess file located? I'm struggling to find it in any of the directories.

    Leave a comment:


  • Wayne Luke
    replied
    You need to edit your .htaccess file and direct either www.* or * to the URL you want to use.

    See this page here: http://stackoverflow.com/questions/1...using-htaccess

    Leave a comment:


  • italynstylion
    replied
    How do I direct traffic to the correct URL? What changes do I need to make?

    Leave a comment:


  • italynstylion
    replied
    ^That is my thought as well. Can you please look at my settings below and let me know what I'm doing wrong? (I censored any sensitive info so it should be clean)

    Leave a comment:


  • Zachery
    replied
    You're still not redirecting traffic to the correct url.

    Leave a comment:


  • italynstylion
    replied
    No dice....still does the same thing.

    Log in, throws you back to the forum index where you are NOT logged in...then if you click the forum tab or the banner you get taken to a SLIGHTLY different URL and you ARE logged in. This is driving me insane!

    Leave a comment:


  • BirdOPrey5
    replied
    Originally posted by italynstylion View Post
    Can you explain that process a little more in depth? I'm not familiar with it and would rather not screw it up.
    The config.php file is located in your /includes/ folder. It needed to be edited when vBulletin was first installed.

    One of the lines it it specifies a "Cookie Prefix" the default prefix is bb and yours is likely default.

    Download a copy of your config.php file, edit it in a good text editor like Notepad2 or Notepad++ (not the built in Windows notepad) and find and change the the cookie prrefix. You can change it to anything you want but it should be short and be letters and numbers only. So changing it from bb to vb is fine.

    At this point I suggest you rename your old config.php file to configOLD.php and then upload the edited copy in its place. Just in case something goes wrong you have a copy of the original file.

    NOTE- it is ESSENTIAL the old copy of config.php keeps the .php file extension. If you name it config.php.old then anyone can view it in a web browser and see all your private settings in plain text. As long as it has a .php extension however it will be blank if anyone tried to view it directly.


    The act of resetting the prefix basically means every user will have to download fresh cookies. It is easier than asking every user to clear their cookies manually.

    Leave a comment:


  • italynstylion
    replied
    Can you explain that process a little more in depth? I'm not familiar with it and would rather not screw it up.

    Leave a comment:


  • Zachery
    replied
    Bad cookies from the mixed domains will continue to cause problems going forward. To make sure everyone is on new cookies, in the config.php file change the cookie prefix from bb to vb. Everyone will be logged out once.

    Leave a comment:


  • italynstylion
    replied
    Still having the same problem. Not sure why it doesn't remember the user even if they click "remember me".

    Leave a comment:


  • italynstylion
    replied
    I think that fixed the redirect issue! Thanks guys.

    So that first part is fixed. I'm still not staying logged in though. The log in takes my credentials and redirects me to domain.com/forum instead of the http://www.domain.com/forum
    When I get to the page that it's redirected me to I am NOT logged in (even though I was redirected there after logging in). But if I click the forum tab it gets me to the correct http:// domain address and I'm logged in....puzzles me

    Leave a comment:


  • snakes1100
    replied
    You can paste your alternate url into the Redirect Domain Whitelist box under the Site Name / URL / Contact Details options.

    If your site uses the URL http://www.domain.com, place http://domain.com into that box, click save, then delete your cookies from your browser, restart it, then log back in.

    Leave a comment:

Related Topics

Collapse

Working...
X