Announcement

Collapse
No announcement yet.

index.php not found on server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] index.php not found on server

    I have completed my test conversion and have run the live conversion from phpBB3 to vBulletin 4.2. Let me tell you, doing those test runs first made the whole live process so mush easier and less painful.

    But now, here is my problem. When I log out of the ACP panel and click on the link to the site in the logon panel OR while in the ACP panel and click on the 'Forum Home Page' link (these are just a few examples), I receive a 'Not Found" screen for 'The requested URL/forum/index.php. was not found on the server. I can go to the address and remove .index.php from the end, hit enter, and go to the home page.

    I currently have my home page set to the 'activity.php' What's New screen.

    Here are the settings I have:
    For my redirect in my cPanel, I have www.******.com/forum/activity.php
    Within the ACP panel, I have Forum URL set to www.*****.com/forum
    Always use Forum URL as Base set to True
    Homepage URL set to www.*****.com/forum/activity.php

    I have tried renaming my forum.php to index.php and visa versa. This did not work.

    This is a basic install of 4.2. I do have 3 mods installed, but they are 3 of the more popular ones. Spam-O-Matic, post_thanks_version_7.83, and YaAS-4.0.6 medals system.

    Regards,

    Ray

  • #2
    Rename forum.php file to index.php then upload to root directory
    MobilePhoneTalk.Com - Mobile Phone Community Powered By EuroVPS.Com

    Comment


    • #3
      Originally posted by rajubd View Post
      Rename forum.php file to index.php then upload to root directory
      The root directory being /forum, where the forum.php and index.php files currently exist, correct? I stated that I tried that already. I downloaded both the forum.php and index.php files, renamed them, renamed the ones on the server by adding a .old extension , then uploaded the renamed files. But will try it again.

      Comment


      • #4
        You should open a ticket in your customer area and leave admincp login informations in the 'sensitive data' box so that we can have a look at it. If you want you can send the ticket to my attention.
        No private support, only PM me when I ask for it. Support in the forums only.

        Comment


        • #5
          Hartmut,

          Will get that done this morning.

          Thanks.

          Comment


          • #6
            Hartmut,

            While setting up access for you, I noticed that when I would get the error page, the address was pointing to 'Index.php', notice the capital 'I'. From my little experience working in the server world, I remembered that in the server world, there is a difference between lower case and upper case. So, I copied my current 'index.php' to 'Index.php' and all seems to be well. Not sure how the capital 'I' version got into the code, but seems to be working.

            Might want to make a note of that.

            Regards,

            Ray

            Comment


            • #7
              Ray, thanks for letting us know and good to see that you fixed the problem.
              No private support, only PM me when I ask for it. Support in the forums only.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X