Announcement

Collapse
No announcement yet.

The user has not registered and therfore does not have a profile to view

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] The user has not registered and therfore does not have a profile to view

    using a fresh install of 4.2.1: http://imgur.com/95iiJFO,FvKAwGG#0

    Please look at this image, as you can see on the bottom left, the URL is pointing to an invalid profile ID for this user, "member.php/RandomGuyX" However, if you look in the url bar up top, you will notice the REAL url, "member.php/11-RandomGuyX"

    If I click on his profile picture on the left, the face, it will link me to a page that says, "The user has not registered and therfore does not have a profile to view".
    Why is the profile image linking to an invalid url?

    Just a heads up, I've gone into the admincp, maintenance and ran the "fix broken profiles" option, this didn't appear to have any effect.

    It's also worth mentioning that inside of options, under "Friendly URLs"

    I have enabled, advanced friendly url's
    strict canonical URL's
    enforce canonical url's for registered users yes,
    friendly url unicode "strip unicode"

    I've tested a few different configurations with these options, none of them fix the issue.

  • #2
    I've replied to your ticket...
    Vote for:

    - *Admin Settable Paid Subscription Reminder Timeframe*
    -
    *PM - Add ability to reply to originator only*
    - Add Admin ability to auto-subscribe users to specific channel(s)
    - "Quick Route" Interface...

    Comment


    • #3
      Yes you did however it does occur with the default profile, do you have any other suggestions? Can you please direct me to where the link is actually built for the profile picture so that I can look at the code?

      Comment


      • #4
        In Friendly URL options set Enforce Canonical URL to Standard, not Strict.

        Comment


        • #5
          Done,

          Still no change,

          member.php?29-HSG-NoahG in the URL when I click on his profile picture from a forum thread,

          From within his profile when I hover over his profile picture, member.php?HSG-NoahG -- which leads to an invalid profile error

          it's like omitting his 29- (userid?) for some reason...

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X