Announcement

Collapse
No announcement yet.

Editor icons not showing up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Editor icons not showing up

    So, I've had this issue for a while now. The icons on my editor wont show up. I've tried replacing the sprite.png, checking my forum url to see if it's correct and I've basically done everything that I could find when searching for topics and people that have the same issue.

    Yes I'm using a custom style, I've tried replacing the editor folder in the customs style folder aswell but no succes. I've tried everything!!!

    Please help!


  • #2
    Create a new style and choose no parent style. This will force it to use the default templates.

    Admin CP -> Styles & Templates -> Style Manager -> [Add New Style]

    Comment


    • #3
      Yea, I did that, the icons show up on the default style but not the custom one.

      Comment


      • #4
        Originally posted by Xcynic View Post
        Yea, I did that, the icons show up on the default style but not the custom one.
        I assume the custom style doesn't have an update. I would run the default style and make changes to the colors using the stylevars.

        Comment


        • #5
          revert the editor.css for the new style. There are 3 .css files revert all three.
          www.cdmagurus.com
          www.cellphone-gurus.com

          Comment


          • #6
            Originally posted by whitey10tc View Post
            revert the editor.css for the new style. There are 3 .css files revert all three.
            Thanks! That worked.

            Comment


            • #7
              You might also need to revert another template also if you have problems while editing a post. It is Postbit_quickedit,
              www.cdmagurus.com
              www.cellphone-gurus.com

              Comment


              • #8
                Originally posted by whitey10tc View Post
                revert the editor.css for the new style. There are 3 .css files revert all three.
                will this screw up and of the personal style changes that we may have made?

                Comment


                • #9
                  Originally posted by Xcynic View Post
                  So, I've had this issue for a while now. The icons on my editor wont show up. I've tried replacing the sprite.png, checking my forum url to see if it's correct and I've basically done everything that I could find when searching for topics and people that have the same issue.

                  Yes I'm using a custom style, I've tried replacing the editor folder in the customs style folder aswell but no succes. I've tried everything!!!

                  Please help!

                  I am having the same issue in both forum and blog. Reluctantly reverted the editor.css file, but no help.

                  I need a quick fix because I don't have time to play with it today. What is suggested? I've uploaed the 4.1.6 files twice. Should I upload the 4.1.5 files again? I want to go back to a working 4.1.5.

                  Comment


                  • #10
                    Originally posted by tsptom View Post
                    I am having the same issue in both forum and blog.
                    You must make sure the images/editor/sprite.png file is uploaded. And, if you have custom styles, it must be uploaded to the style/images/editor directory also.

                    Comment


                    • #11
                      Thanks for your help. The sprite.png looks fine. I don't know what you mean by uploading a custom style. I made all of the changes within VB. I don't have a file that I know of. Also, the problem occurs in the default style as well, if that helps.

                      Also, there is no directory named "style/images/editor" that I can see. cpstyles, perhaps? Can you be more specific? I would appreciate it.

                      Thanks again

                      Comment


                      • #12
                        Originally posted by tsptom View Post
                        Thanks for your help. The sprite.png looks fine.
                        Okay that's good.

                        Comment


                        • #13
                          tsptom-

                          Next, disable all plugins. Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php:

                          define('DISABLE_HOOKS', true);

                          Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates.

                          Admin CP -> Styles & Templates -> Style Manager -> [Add New Style]

                          Comment


                          • #14
                            OK, disable_hooks didn't help, but adding new style did give me a good style. But what does this mean? I have to recreate all of my styles?

                            I noticed that my original default style is now looking correct. It's just my custom style that is messed up.

                            I now see what you mean about uploading the cutom file, but I made so many changes since I uploaded it, I am afraid to upload it.

                            How do I go back to 4.1.5? I have the database.

                            Thanks
                            Last edited by tsptom; Sun 18 Sep '11, 6:48pm.

                            Comment


                            • #15
                              Originally posted by tsptom View Post

                              How do I go back to 4.1.5? I have the database.

                              Thanks
                              You would need to restore from your latest backup. How old is it? You would loose any posts made from that time.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X