Announcement

Collapse
No announcement yet.

4.0.7 Search 404

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 4.0.7 Search 404

    Hi,
    ​I recently took over running a forum running 3.8.7 with an outstanding upgrade to 4.0.7 I have installed the upgrade and everything went well except I lost the search function.

    ​I have rebuilt the search index 4 times with no success.

    I deleted the search.php file and uploaded it again.(followed by a index rebuild)

    There's no errors listed on the server.

    Advance search opens so I can access search.php to some degree.

    I have no plugins installed.

    What's new, view other posts by user and any other search related functions don't work either.


    Has anybody got any ideas or suggestions?


  • #2
    Originally posted by morganoconnell
    Hi,
    ​I recently took over running a forum running 3.8.7 with an outstanding upgrade to 4.0.7 I have installed the upgrade and everything went well except I lost the search function.

    ​I have rebuilt the search index 4 times with no success.

    I deleted the search.php file and uploaded it again.(followed by a index rebuild)

    There's no errors listed on the server.

    Advance search opens so I can access search.php to some degree.

    I have no plugins installed.

    What's new, view other posts by user and any other search related functions don't work either.


    Has anybody got any ideas or suggestions?
    Could be mod_security causing issues.

    Beyond that you'd probably need to upgrade to 4.2.1 or 4.1.12. 4.0.7 is such an old version that there could be bugs affecting what you're trying to do.
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.3 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      This is actually just a bug in php/vBulletin that is resolved early on in 4.1.x series, upgrading to 4.1.12 or 4.2.1 would be your best bet, per marks advice.

      Comment


      • #4
        Cheers lads, it was a conflict with eaccelerator, I just needed to edit the init.php file to make an allowance for it.

        The forum is used as a contact point for a small club. There's no money made from it and so no money available for an upgrade right now.

        Comment


        • #5
          Ah, you're on a vB3 license all together. I'd honestly recommend looking into upgrading at some point, both for security and performance reasons. At least put it on the table.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X