Announcement

Collapse
No announcement yet.

Cant disable plugins and hooks after update to 4.2.1

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Cant disable plugins and hooks after update to 4.2.1

    Hi all

    I just updated to latest version 4.2.1, I now find if i disable hooks and plugins (settings or config.php) all i get is a blank screen trying to load forums.

    Is anyone else having this issue.


    Any advice appreciated.
    http://www.vrbforums.com/forum/index.php

  • #2
    What are the server logs saying when you get the blank pages?
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.4 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      I just checked the log and it appears the error is from the side blocks and an addon that is using the blocks.

      I disabled sideblocks and its fine ive put error message below.

      Code:
      [Thu Apr 18 13:48:38 2013] [error] PHP Fatal error:  Class 'DBTECH_GALLERY' not found in /home/webadmin/fish-keeping.com/html/forums/includes/block/dbtech_gallery.php on line 190
      http://www.vrbforums.com/forum/index.php

      Comment


      • #4
        Cant you simply remove the specific widget from the side block?
        No private support, only PM me when I ask for it. Support in the forums only.

        Comment


        • #5
          Originally posted by Hartmut View Post
          Cant you simply remove the specific widget from the side block?

          I could but it worked fine before upgrade
          http://www.vrbforums.com/forum/index.php

          Comment


          • #6
            When a class isn't found, that usually means a file is missing. Did you accidentally delete some modification files when you uploaded new files for the upgrade?

            Please don't PM or VM me for support - I only help out in the threads.
            vBulletin Manual & vBulletin 4.0 Code Documentation (API)
            Want help modifying your vbulletin forum? Head on over to vbulletin.org
            If I post CSS and you don't know where it goes, throw it into the additional.css template.

            W3Schools <- awesome site for html/css help

            Comment


            • #7
              Originally posted by Lynne View Post
              When a class isn't found, that usually means a file is missing. Did you accidentally delete some modification files when you uploaded new files for the upgrade?

              Not that im aware of, unless they were replaced by the mod, but looking at the install its files are in a folder not accessed by Vb files uploaded.

              I will reupload the mod files and test that this isnt the case.
              http://www.vrbforums.com/forum/index.php

              Comment


              • #8
                I have reuploaded the mod and installed it, unfortunately the result is the same when plugins and hooks are disabled blank white screen appears.

                error log same as above.
                http://www.vrbforums.com/forum/index.php

                Comment


                • #9
                  What if you only disable the dbtech gallery in admincp? And remove the widget in the sideblock?
                  No private support, only PM me when I ask for it. Support in the forums only.

                  Comment


                  • #10
                    Disabling gallery forum works ok, it also disabled its own sideblocks, disabling plugin and hooks while gallery disabled forum loads ok,
                    so must be something not being disabled globally but is disabled by the gallery itself.


                    One for the boffins to figure I think, now I know what the cause is I can work round it.


                    I will bring this up in the gallery thread on vb.org.
                    http://www.vrbforums.com/forum/index.php

                    Comment


                    • #11
                      Originally posted by Red-Devil View Post
                      I will bring this up in the gallery thread on vb.org.
                      Getting in touch with the author of this addon would be the best step now.
                      No private support, only PM me when I ask for it. Support in the forums only.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X