Announcement

Collapse
No announcement yet.

Email notifications issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Email notifications issue

    Hello,
    I've ran into a problem since this morning regarding my forum.
    One of the admin sent a mass pm to all users. She received an error saying that some users were not found (I don't know whether this is relevent or not, but I prefer to give the whole context).
    Anyway, since then the emails regarding the notifications (and only the notifications) stopped working: PM notifications fail, as well as notifications of a new message in a subscribed topic.
    I tried the diagnostic tool in maintenance and it works just fine, I receive the mail. Same goes for registration of new users, the mail are correctly received.
    At first, I thought it had something to do with sendmail being buggy, so I tried several modifications without much success. In the end I decided to switch for postfix. I removed entirely sendmail and installed postfix.
    But the problem remains as it is: the mail function of php seems to work fine, but the notifications aren't sent.
    I have found no message in the log showing that even a message is sent (mail.log, mail.err or even syslog - I checked them all; The messages concerning the diagnostics/registrations do appear though).
    I also tried to use smtp rather than mail(), I modified the configuration to use gmail's smtp: The problem remained identical (diagnostic/registration mail correctly sent but not the notifications).

    I tried as well to activate notifications using this method: https://kb.siteground.com/enable_pri...ulletin_users/
    (Though, no settings should have been changed since the problem appeared so I didn't have much hope with this method).

    There's definitly something I missed, but so far I didn't manage to understand what's happening exactly.

    Other informations that might help:
    Host: OVH (It's a Dedicated)
    OS: Debian Squeeze
    Web server: apache 2.2

    Thanks

  • #2
    If you haven't tried the options listed here, you should.

    Comment


    • #3
      Actually, I did. And nothing worked.
      But I finally managed to find out what was causing the issue.
      In Settings >> Options >> Email Options, there is an Use Mailqueue System option that was set to Yes in my case. I changed it to No, and the notifications worked again.
      Seems like many mails were hold to be sent in batch.

      Anyway, now it works

      Comment


      • #4
        When emails are getting sended in batches, you can see this at admincp home under 'Number of Queued E-Mails'.
        No private support, only PM me when I ask for it. Support in the forums only.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X