Announcement

Collapse
No announcement yet.

CKEditor is not activated, How to activate it?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] CKEditor is not activated, How to activate it?

    Hello there,

    I have upgraded from 4.1.3 to 4.1.5, its a clean installation, I don't have any mod installed yet. But I noticed that my CKEditor is not activated, I double checked my settings at /profile.php?do=editoptions its "Enhanced Interface - Full WYSIWYG Editing" I also enabled that in "Message Posting Interface Options".

    Screenshot of my "Enhanced Interface - Full WYSIWYG Editing"

    Click image for larger version

Name:	img.jpg
Views:	1
Size:	26.4 KB
ID:	3721235

    Can somebody help me to troubleshot it?

    Thanks.

  • #2
    Do you have javascript disabled in your browser?

    Comment


    • #3
      No, I'm using Firefox 5.0 and checked javascript already enabled.
      I can see and use CKEditor here on vB.com

      Comment


      • #4
        It's acting like there is not javascript. Are you doing any sort of compression on your server?

        Comment


        • #5
          GZIP HTML Output option is enabled, but I also tried by disabling it, still doesn't work.

          What are other options of compression? where I can check?

          Comment


          • #6
            Have you checked for suspect files?

            Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

            Comment


            • #7
              First, make sure you have the WYSIWYG Editor enabled here:

              Admin CP -> Settings -> Options -> Message Posting Interface Options -> Enable Clickable Message Formatting Controls

              Then make sure you have selected the Enhanced editor in your user Settings:

              Settings -> Edit Options -> Message Editor Interface -> Enhanced Interface

              If you see the editor without the images, then this means you have not uploaded the 'images/editor/sprite.png' file. You need to do that.

              Then make sure you have all BB Code options enabled here:

              Admin CP -> Settings -> Options -> BB Code Settings -> Enabled Built-in BB Codes

              And have set this:

              Admin CP -> Settings -> Options -> BB Code Settings -> Allow BB Code in Non Forum Specific Areas -> Yes

              Note: If you have any custom styles, then you also need to upload or copy the 'images/editor/sprite.png' file to the directory(ies) used for your custom styles.

              You can check for the correct directory in the ImagePath Stylevar settings:

              Admin CP -> Styles & Templates -> Style Manager -> style name -> StyleVars -> ImagePath

              Also please note that custom BB Codes can also interfere with the new editor. You may need to remove those if you have any.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Thank you Andy and Steve, there was some files missing, after running the Suspect File Versions I found the problem, and its fine now.

                regards,
                Veer.

                Comment


                • #9
                  Glad to hear it.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X