Announcement

Collapse
No announcement yet.

Admin control panel - user manager: Warning: Illegal string offset errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Admin control panel - user manager: Warning: Illegal string offset errors

    vBulletin 4.1.7. (Upgrade isn't possible due to configuration issues.)

    I'm having problems with the user manager page after an upgrade to PHP 5.4.13. In the User Profile Fields form area, I get the following errors after the Location field.

    Warning: Illegal string offset 'userid' in [path]/includes/functions.php on line 701

    Warning: Illegal string offset 'userid' in [path]/includes/functions.php on line 704

    Warning: Illegal string offset 'usergroupid' in [path]/includes/functions.php on line 644

    Warning: Illegal string offset 'usergroupid' in [path]/includes/functions.php on line 710

    Warning: Illegal string offset 'userid' in [path]/includes/functions.php on line 710
    Here's what it looks like (This is a spammer I just banned.)



    This error seems unique; I haven't been able to find any reference to it anywhere else here.
    Last edited by cyburbia; Wed 27 Mar '13, 6:11am.
    Cyburbia Forums - a third place for urban planners
    http://www.cyburbia.org/forums

  • #2
    vBulletin 4.2.0 has issues when running with PHP 5.4. Do you have any chance of downgrading to PHP 5.3 again?
    No private support, only PM me when I ask for it. Support in the forums only.

    Comment


    • #3
      Originally posted by Hartmut View Post
      vBulletin 4.2.0 has issues when running with PHP 5.4. Do you have any chance of downgrading to PHP 5.3 again?

      Maybe. Isn't PHP 5.3 end-of-life, though?

      Is there any kind of workaround?
      Cyburbia Forums - a third place for urban planners
      http://www.cyburbia.org/forums

      Comment


      • #4
        You could try to disable error posting in php.ini in order to suppress the error text.
        No private support, only PM me when I ask for it. Support in the forums only.

        Comment


        • #5
          You're going to have issues with VB 4.1.7 and PHP 5.4.x anyway, downloading PHP is your only real option if upgrading VB isn't possible. A VB upgrade would need to be the next version (4.2.1) not 4.2.0 either.

          Comment


          • #6
            Downgraded to 5.3. Thanks for your response.
            Cyburbia Forums - a third place for urban planners
            http://www.cyburbia.org/forums

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X