Announcement

Collapse
No announcement yet.

Invalid Redirect URL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Invalid Redirect URL

    On my board if you try logging in without including the www in the address bar (ie: mysite.com or http://mysite.com), it will give the redirect error. If I include www.mysite.com and login, there will be no issue, as it should be. I currently cannot use .htaccess and force a rewrite as my site resides on a server that is running nginx. My Forum URL in the Admin CP looks to be correct, http://www.mysite.com/forum

    Browsers that automatically add a www will not be affected by this, but there are some browsers that don't.

    Is there anything I can do to remedy this, or will I need to get in contact with my host?

    Thank you
    Last edited by mike406; Thu 21st Mar '13, 12:51pm.
    vBulletin.org Profile

  • #2
    I've never seen a browser auto add www. https yes, www, no. Would be a bad idea.

    In your Admin CP -> Settings -> Options -> Site Name / URL / Contact Details there is a setting: Redirect Domain Whitelist

    Add http://yoursite.com there and save. It should work now.

    Comment


    • #3
      Well that certainly was easier than I had thought it'd be. I also had to change my cookie settings from (blank) to .domain.com, since the logins weren't "sticking" between http and www

      Thank you!
      vBulletin.org Profile

      Comment

      Related Topics

      Collapse

      Working...
      X