Announcement

Collapse
No announcement yet.

Database error after server move

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Database error after server move

    I just recently changed servers. I am getting a database error every time I try to post or start a new thread. the error is duplicate of the Primary. I can't figure out what table it is. I have run the database repair tool and still I get this error. Checking the database tables I notice that searchcore and searchcore_text are reporting that they have ~552,790 and ~184,208 rows. How can I repair this error?
    Vote for my suggestions here and here

  • #2
    Please post the full database error.

    Have you tried running the "Fix Unique Indexes option in Admin CP -> Maintenance -> Repair / Optimize Tables (at bottom of the page)?

    Comment


    • #3
      You can truncate the searchcore, searchcore_text, searchgroup and searchgroup_text tables. Then you'll need to rebuild your search index in the Admin CP under Maintenance -> General Update Tools.
      Translations provided by Google.

      Wayne Luke
      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
      vBulletin 5 Documentation - Updated every Friday. Report issues here.
      vBulletin 5 API - Full / Mobile
      I am not currently available for vB Messenger Chats.

      Comment


      • #4
        Originally posted by Joe D. View Post
        Please post the full database error. Have you tried running the "Fix Unique Indexes option in Admin CP -> Maintenance -> Repair / Optimize Tables (at bottom of the page)?
        I tried that, and it said that the indexes were already unique.

        Originally posted by Wayne Luke View Post
        You can truncate the searchcore, searchcore_text, searchgroup and searchgroup_text tables. Then you'll need to rebuild your search index in the Admin CP under Maintenance -> General Update Tools.
        Thanks for this suggestion. I actually just dropped all the tables and imported another dump I made around the same time and it worked fine.
        Vote for my suggestions here and here

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X