Announcement

Collapse
No announcement yet.

Facebook "Like" Thread Title is Forum Name not thread Name

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] Facebook "Like" Thread Title is Forum Name not thread Name

    Hello guys,

    I was running 4.1.3 and found a issue in the facebook like button, so I upgrade to new version to see If fix the issue, but Im now running last version (4.1.5) and the issue continues... Can someone help me?

    The issue:

    I've enabled the vBulletin Facebook feature and have it working, except that the title shown on Facebook is the Forum Title, not the Thread Title when liking a thread. The link works fine and goes to the correct thread though. Basically, I get on Facebook "Sofia Andrade likes Viciados no Sexo." instead of "Sofia Andrade likes Thread Title.

    The same happens with the description, the description shown on Facebook is the Forum Description, not the Thread Content...

    I've searched through this forum for info, but can't find anything that fixes this. Please help.

    Please check:
    http://screensnapr.com/e/UINaRP.jpg

  • #2
    Confirming the same issue.
    http://www.zazdravje.com.mk

    Comment


    • #3
      Works fine when I like this thread here. To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

      Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

      [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

      Next, disable all plugins.Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php:

      define('DISABLE_HOOKS', true);

      Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.

      Do you have the same problem?
      Vote for:

      - *Admin Settable Paid Subscription Reminder Timeframe*
      -
      *PM - Add ability to reply to originator only*
      - Add Admin ability to auto-subscribe users to specific channel(s)
      - "Quick Route" Interface...

      Comment


      • #4
        Thank you or our reply Trevor.
        Damn.. I did everything what you said, and still have the problem...
        Also, I have all the original files, because I did a upgrade, only kept config.phpWhat could be?Any idea to fix this, please?
        Last edited by EN1GMA; Tue 9 Aug '11, 2:13am.

        Comment


        • #5
          Please, can someone help me?

          Btw, this is my Suspect File Versions result:


          I don't understand why is appearing this files... both are original!
          Please help me fix this issue...

          EDIT:
          This is my code source from a thread page:
          Code:
          <meta property="fb:app_id" content="187129424635219" />
          <meta property="og:site_name" content="Viciados No Sexo" />
          <meta property="og:description" content="Viciados no Sexo é o melhor forum de sexo em Portugal onde podes encontrar milhares de utilizadores que partilham fotos e videos de sexo gratis, e discutem todo o tipo de assuntos sem tabus. O registo é gratuito." />
          <meta property="og:url" content="http://www.viciadosnosexo.com/forum/showthread.php/131221-Estamos-de-volta-!!!" />
           <meta property="og:type" content="article" />
          <meta property="og:image" content="http://www.viciadosnosexo.com/forum/images/facebookvns.jpg" />
          Thats why is not appearing the thread title and description... as we can see, only show website name and description
          Last edited by EN1GMA; Tue 9 Aug '11, 2:39am.

          Comment


          • #6
            Btw:

            Testing the URL at http://developers.facebook.com/tools/lint/

            My URL:
            http://screensnapr.com/e/Alp2i8.jpg

            This vbulletin.com thread URL:
            http://screensnapr.com/e/4stDrc.jpg

            The problem is in the title... how can I fix that?

            Comment


            • #7
              hmmm was thinking... my board is closed since 2 months ago, could be the reason of this issue?
              but I opened a few seconds to test, and the problem continues... even using the facebook link tool.

              Comment


              • #8
                Can't replicate this on my own test site either - shows the name of the thread correctly there as well...
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - "Quick Route" Interface...

                Comment


                • #9
                  Originally posted by EN1GMA View Post
                  hmmm was thinking... my board is closed since 2 months ago, could be the reason of this issue?
                  Yes. The spider from FB is a guest. If the only thing a guest sees is the board name (because it's closed), then yes, that's all it can see.
                  but I opened a few seconds to test, and the problem continues... even using the facebook link tool.
                  For pages you haven't already tried to link? It would need to be a new page, FB has already visited the old one, and seen that its title is "Board Closed". It won't bother again.
                  My Live vB5 Site - NZEating.com
                  vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

                  Comment


                  • #10
                    Fixed! The thread that I was testing, was not readable for guests, that's why doenst appear the thread title lol. (Shame)

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X