Announcement

Collapse
No announcement yet.

"upload file failed"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Forum] "upload file failed"

    get this message each time i try to upload a file .

    i didnt have this error before ( i own vb like 3 years) and it just started lately after upgrading to 4.1.5 PL 1

    Here is the diagnostics info:

    file_uploads:On
    open_basedir: /home:/home/tmp:/var/www/html
    safe_mode:Off
    upload_tmp_dir:None
    upload_max_filesize:32.00 MB

    Results : No file uploaded and no local file found. The test cannot continue.
    Last edited by Emath; Sun 7th Aug '11, 12:02am.
    בגרות במתמטיקה | פתרונות לספרי לימוד

  • #2
    Are you storing the attachments in the database or the filesystem?

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main hosting directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

      home/tmp

      Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Safe Mode Temporary Directory

      Admin CP -> Settings -> Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled -> Yes

      Also the php.ini setting for 'upload_tmp_dir' is empty. It's possible you (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd t
      o 1777. You will also need to restart Apache after making this change.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        i didnt do anything and suddenly it started to work again as before :S

        thanks anyway !
        בגרות במתמטיקה | פתרונות לספרי לימוד

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X